VIDE and Pakrat not working

Discussion in 'Mapping Questions & Discussion' started by Mr. Kabanos, Jul 31, 2016.

  1. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Hi , I have map with custom models/materials (Frontline Model Pack) and I want to all people see them correctly. I used VIDE and Pakrat but they are not working properly. Can you help me out? Please.


    -Mr. Kabanos
     
  2. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    Define "not working properly"
     
  3. Viperi

    aa Viperi not actually a snek

    Messages:
    962
    Positive Ratings:
    530
    I assume the definition is improperly packed.
     
  4. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    When I am uploading map to Steam Workshop everyone who don't have models installed see Errors and pink and black texture on roofs etc.
     
  5. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    697
    Positive Ratings:
    198
    Run us though what you are doing step by step for both Vide and Pakrat, particularly if you are following any guides/instructions for them.
     
  6. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
  7. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    Are you actually saving the BSP after going through the steps?
     
  8. Vel0city

    aa Vel0city personal pick-pocketing parrot

    Messages:
    1,883
    Positive Ratings:
    1,488
    I've had recent issues with VIDE not packing stuff (you can test it on your own by starting TF2, opening the console and typing sv_pure 2. If the game shows missing content or outright crashes, congratulations you have unpacked content). I switched to CompilePal (which I already use for compiling anyway), checked the Pack function, and it worked first time. I'm using that from now on, because it works.

    Try using CompilePal instead of Vide. Don't even bother with Pakrat, it's outdated as balls.
     
  9. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Yeah
     
  10. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    697
    Positive Ratings:
    198
    What is the size of the .bsp file before and after packing? It should go up once the content is packed in. If it does not go up, it has not been saved.
     
  11. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Size of .bsp go up a lot.
     
  12. Yrr

    aa Yrr An Actual Deer

    Messages:
    984
    Positive Ratings:
    1,871
    here's a Q, is the .bsp you're uploading the tf/maps file or the file hammer creates in the same folder as the. vmf?
     
  13. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    697
    Positive Ratings:
    198
    Are you uploading that version of the map?
     
  14. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Yep.
     
  15. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I will check it
     
  16. Mr. Kabanos

    Mr. Kabanos L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Actually , yes when I saw this I compiled a map and packed everythink again and upload it to the workshop. Still got errors
     
    Last edited: Jul 31, 2016
  17. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    697
    Positive Ratings:
    198
    Maybe try packing with BspZip, and instead of uploading to the workshop load the map on a local server with sv_pure 1