what's wrong with ma beautiful cart

Discussion in 'Mapping Questions & Discussion' started by 咕噜and呼噜, Nov 4, 2018.

  1. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    before i built trackz, i can push it all the day
    MP_E_D2.png
    but after i build the hot hard track for ma pretty cart
    holy crab , it fall in love with trackz, i cant separate them at all!
    MP_E_D1.png
    i cant find anything problem, can someone help me fix it?
    MP_E_D3.png
     

    Attached Files:

  2. Sandwhip

    aa Sandwhip

    Messages:
    207
    Positive Ratings:
    105
    if there's collision on the tracks, it's likely that the payload is colliding with them, impeding its movement
     
  3. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    but those trackz is "no solid"
     
    Last edited: Nov 4, 2018
  4. Yrr

    aa Yrr An Actual Deer

    Messages:
    1,166
    Positive Ratings:
    2,327
    you should write this Normally if you want people to take you seriously
     
    • Agree Agree x 9
  5. Dan On Yernan

    Dan On Yernan L1: Registered

    Messages:
    41
    Positive Ratings:
    2
    you need to set your first path tracks destination to 'sspl_path_A_1', it is currently set to 'sspl_path_start1', which doesnt exist, so your cart has nowhere to go
     
  6. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    wow it works,but........where is my hud?
    MP_E_D4.png
     
  7. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    ummm.....k
    "my bombcart stuck in the track after i build the track"
    but why the water and wooden platform are covered with "missing texture"?
     
  8. Dan On Yernan

    Dan On Yernan L1: Registered

    Messages:
    41
    Positive Ratings:
    2
    go into the ABS gametype library where you got the payload cart from, and you'll find some entities that are called 'team_train_watcher', 'team_control_point_master' and some other entities. Copy and paste these into your map. Use https://developer.valvesoftware.com/wiki/TF2/Creating_a_Payload_Map to help you out with filling in the logic, as the names of the path tracks in your map are different to the ones in the entities, and that link should tell you what to put
     
  9. DrSquishy

    aa DrSquishy ???

    Messages:
    1,157
    Positive Ratings:
    683
    The missing texture is because you've placed env_cubemap entities but not built cubemaps. As the entities have been placed, no default cubemap is there, but you've not built any reflections so there is nothing to 'reflect'. Just type `buildcubemaps` into the console or remove the entities
     
    • Agree Agree x 2
  10. henke37

    aa henke37

    Messages:
    2,028
    Positive Ratings:
    488
    Nowhere, because you forgot the trainwatcher entity.
     
  11. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    oof,i typed "-dev -console +sv_lan 1 +buildcubemaps" at "additional game parameters"
    MP_E_F1.png
    and placed 2 cubemaps
    MP_E_F2.png
    but seems it not works
    MP_E_F3.png
     

    Attached Files:

  12. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    umm......i already copied it
    MP_E_F4.png
    and this image shows that it had hud before i build tracks = =
    [​IMG]
     

    Attached Files:

  13. Viemärirotta

    aa Viemärirotta sniffer

    Messages:
    1,003
    Positive Ratings:
    568
    When you build your cubemaps, you need to reload the map again, not to mention you can't "buildcubemaps" right off the bat you need to have mat_specular 0 to make the cubemaps built properly (after which you return mat_specular 1 when restarting the level, without compile of course, otherwise you'll lose the cubemaps!)
     
  14. Dan On Yernan

    Dan On Yernan L1: Registered

    Messages:
    41
    Positive Ratings:
    2
    do you have the vmf before you added the tracks saved?
     
  15. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    yeah, it's v111
     

    Attached Files:

  16. Dan On Yernan

    Dan On Yernan L1: Registered

    Messages:
    41
    Positive Ratings:
    2
    make sure all the path track names in the team_train_watcher are correct, after linking the sspl_path_start to sspl_path_A_1 it worked fine for me and i got a hud. ive got the fixed vmf so you can take a look
     

    Attached Files:

  17. 咕噜and呼噜

    咕噜and呼噜 L1: Registered

    Messages:
    28
    Positive Ratings:
    2
    wow, i forget this, thanks alot
     
Tags: