Building Facelights Freezes Up PC

Discussion in 'Mapping Questions & Discussion' started by Snazzy Jovial Wyrm, Apr 10, 2019.

  1. Snazzy Jovial Wyrm

    Snazzy Jovial Wyrm L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    As the title suggests, I've been getting an odd hiccup whilst building facelights during compilation. It's happened three times so far and I have no idea what is causing it as I hadn't even added much in that could possibly effect facelights in such a way. CompilePal doesn't give any errors on the issues at all. It counts up the numbers for facelights up until 4 or 5, which is where my PC crashes and freezes.

    I have a GTX 1060, AMD FX(tm) -8350 Eight Core Processor, and up to 12GB of RAM, if that's any constellation.
     
  2. comradecommie

    comradecommie L3: Member

    Messages:
    138
    Positive Ratings:
    48
    Sounds like an issue with your map. Leaks? Is it on grid?
     
  3. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,123
    Positive Ratings:
    766
    I've occasionally gotten computer stutters while running VRAD in the background, but these usually last less than a second and have never caused a total PC crash. The most I can recommend is to set VRAD's priority to Low, which prevents the aforementioned stutters. If you're using the recent beta (026), this can be done in CompilePal natively. If you're using version 025, you have to either modify CompilePal's files to add this parameter to VRAD or set the priority manually in Task Manager.
     
  4. Snazzy Jovial Wyrm

    Snazzy Jovial Wyrm L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    No leaks at all. The map in itself is an edited version of Degroot Keep which will be for Gmod.
     
  5. Snazzy Jovial Wyrm

    Snazzy Jovial Wyrm L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Alas, this did not work. It seems like something in my map is causing facelights to crash my whole PC. I have no idea what, though.
     
  6. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,703
    Positive Ratings:
    351
    have you run your compile log through interlopers?
     
  7. Viemärirotta

    aa Viemärirotta sniffer

    Messages:
    1,006
    Positive Ratings:
    568
    Could you have altered something that directly affects lighting in VRAD, perhaps entities or adjusting lightmaps. Alternatively, of course there could be brushwork that's very complex or for some reason hard for VRAD to process. Try using cordon and compiling the map in segments, starting from areas you haven't touched to parts you have made work on. Perhaps you can figure out from there.
     
  8. Snazzy Jovial Wyrm

    Snazzy Jovial Wyrm L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    I have, but it's just giving me the same stuff that Compile Pal gives me, so no help there.

    I managed to do a full compile with having all props hidden, so something tells me it may have something to do with the amount of props inside my map, which I don't see why because there's only around 600 or so props. It could very well be a overheating problem with my CPU, so I'm gonna have my dad clean my computer out later on and then see afterwards.
     
  9. Kill_the_Bug

    aa Kill_the_Bug

    Messages:
    1,703
    Positive Ratings:
    351
    Ok, do this then - use the bounding box method - the icons on the top of hammer do a large section of your map - find out the parts that are working (after comipling) vs the parts that aren't. In the parts that aren't start shrinking the box down until you find the error. Something tells me that you might have an entity i.e. light inside a brush - this will cause a crash of your map < easy to make the mistake and bitch to find.
     
  10. Yrr

    aa Yrr An Actual Deer

    Messages:
    1,123
    Positive Ratings:
    2,220
    Your pc might just not be able to handle VRAD, potentially use one of the compilers that does threading (ie compilepal) and see if that still hangs your entire pc?
     
  11. Snazzy Jovial Wyrm

    Snazzy Jovial Wyrm L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Apologies, but I managed to fix the problem by deleting a couple of unwanted/obscurred props in the map yesterday. Thank you all for replying, though.