Hdr compiling causes fullbright on map

Discussion in 'Mapping Questions & Discussion' started by Grubzer, Jul 20, 2016.

  1. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    Compiling with hammer and Compile Pal 23x with hdr on causes a map to be fullbright (forces mat_fullbright 1)
    Compiling without hdr enabled - no problem.

    hammer hdr vrad settings:
    -hdr -final -game $gamedir $path\$file

    Compile Pal hdr vrad setting:
    -final -StaticPropLighting -StaticPropPolys -hdr -game $game$ $vmfFile$
     
  2. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,540
    If you have -hdr you will only compile in HDR (high dynamic range), not LDR(low dynamic range, the setting the game runs at with standard settings). Your game is most likely set to LDR only, so it can't find any lighting for LDR and then applies fullbright to your level. If you want to compile with standard LDR lighting as well, compile with both -ldr and -hdr. There's also a -both option, but that one is known to crash the compiler/not compile HDR at all. So just use -ldr and -hdr.
     
    • Agree Agree x 1
  3. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    How do i set my game to hdr?
     
  4. Another Bad Pun

    Server Staff Another Bad Pun punished nerd

    Messages:
    594
    Positive Ratings:
    1,284
    I'm pretty sure you can compile with only -ldr and cause no issues, but compiling with -hdr only will probably cause problems.
    Using the -both variable works on the standard compiler just fine, I'm not sure why it wouldn't work in compile pal.

    If your computer can run HDR, you can enable it in Video Options or through the developer console.
    mat_hdr_level 0 is LDR
    mat_hdr_level 2 is standard HDR
     
  5. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    369
    Positive Ratings:
    278
    There's something I've always wondered, though. What's mat_hdr_level 1? It doesn't seem to do anything whenever I try to use it.
     
  6. Another Bad Pun

    Server Staff Another Bad Pun punished nerd

    Messages:
    594
    Positive Ratings:
    1,284
    ¯\_(ツ)_/¯
    it probably does nothing tbh
     
  7. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    Mat_hdr_level 1 is ldr + bloom
     
    • Thanks Thanks x 1
  8. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
  9. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
  10. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,377
    Probably because you didn't set the exposure limits. The defaults are pretty extreme, for some reason — maybe to alert you that you compiled in HDR without setting them manually. Anyway, I recommend looking up env_tonemap_controller and how to use it.
     
    Last edited: Jul 21, 2016