[SOLVED] Skybox displacements appear differently in-game

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

FloofCollie

I really suck!
aa
Nov 5, 2016
598
In Hammer, the displacement terrain in the 3D skybox is quite clearly lined up properly with the props (the props are even sunk into it a tiny bit), yet in-game it appears as though the props are floating above it.
20180423191325_1.jpg

hammerproblem1.png

Tried recompiling, same problem. Any ideas?
 

FloofCollie

I really suck!
aa
Nov 5, 2016
598
Ran it through interlopers.net's compile log checker, which didn't find anything I wasn't already aware of.

** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_cowbell_a2.vmf"
Valve Software - vbsp.exe (Mar 6 2018)
4 threads
materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_cowbell_a2.vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Patching WVT material: maps/koth_cowbell_a2/nature/blendgroundtograss001_wvt_patch
Patching WVT material: maps/koth_cowbell_a2/nature/blendgrassground002_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 434 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_cowbell_a2.prt...Building visibility clusters...
done (0)
*** Error: Skybox vtf files for skybox/sky_granary_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_granary_01 to build the default cubemap!
*** Error: Skybox vtf files for skybox/sky_granary_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_granary_01 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (1) (206125 bytes)
Error! To use model "models/player/hwm/sniper.mdl"
with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/player/hwm/sniper.mdl"!
Error! To use model "models/player/hwm/pyro.mdl"
with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/player/hwm/pyro.mdl"!
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 344 texinfos to 183
Reduced 37 texdatas to 35 (846 bytes to 766)
Writing C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_cowbell_a2.bsp
Wrote ZIP buffer, estimated size 1163, actual size 949
5 seconds elapsed
** Executing...
** Command: Copy File
** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_cowbell_a2.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\koth_cowbell_a2.bsp"
 

FloofCollie

I really suck!
aa
Nov 5, 2016
598
So I've decompiled the map to work on it again and this problem still persists. I guess I'll have to manually offset either the props or the displacements and compile until they match?
 

FloofCollie

I really suck!
aa
Nov 5, 2016
598
Okay, nvm, now the props show up properly in the editor for some reason. I have no idea what caused this :p