TF2M Migration Bugs

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Zeus

Not a Krusty Krab
aa
Oct 15, 2014
267
Embedded images in threads such as this one appear to be broken.

We are unsure why those images specifically dont show up; but we have a fix for attachments not being able to cross over between posts
https://tf2maps.net/threads/bb-code-test-thread.45903/#post-489373
https://tf2maps.net/downloads/craggy-coast.8912/updates?page=2#resource-update-22191

We are still looking into the issue on that lighting thread. If you encounter more examples of images that cant be loaded at all please let us know. We're trying to figure out how widespread that issue is
 

nesman

master of fast travel
aa
Jun 27, 2016
898

nesman

master of fast travel
aa
Jun 27, 2016
898
Last edited by a moderator:

Call_Me_Meme

L1: Registered
Apr 21, 2018
30
It seems like my Steam Account was disassociated with my TF2Maps account. Trying to sign-in via Steam brings me to the account registration page and my Steam Account doesn't appear in Connected Accounts Page
1644760431340.png
 

nesman

master of fast travel
aa
Jun 27, 2016
898
It seems like my Steam Account was disassociated with my TF2Maps account. Trying to sign-in via Steam brings me to the account registration page and my Steam Account doesn't appear in Connected Accounts Page
1644760431340.png
Correct. This was in a recent announcement. You need to re-add it.
"Due to an issue with our login system, if this is your first time logging in after the migration (Feb 8, 2022) and you used Steam to log in, you must reset your TF2maps password to log in."
 

SaltyPapi

L1: Registered
Mar 11, 2021
35
The download button for the feedback .vmf has disappeared ever since the transfer, and I am also unable to claim my map. Might have something to do with the fact that I'm not signed in through steam, but every time I try, it returns an error message (HTTP ERROR 500), as being unable to handle my request.


download button.PNG
 

Zeus

Not a Krusty Krab
aa
Oct 15, 2014
267
The download button for the feedback .vmf has disappeared ever since the transfer, and I am also unable to claim my map. Might have something to do with the fact that I'm not signed in through steam, but every time I try, it returns an error message (HTTP ERROR 500), as being unable to handle my request.


download button.PNG
ah right i totally forgot people could login to the site. ill look into this
 

TheWither031

L1: Registered
Mar 3, 2021
9
Button is either missing or text is misaligned

1645046387568.png


How to reproduce:
Go to the account details section in settings
 

Tang

aa
Aug 18, 2018
111
Bug: Text and buttons are shifted off the menu window of the "Manage Cover" feature when you add more than one picture
1645073986860.png

How to reproduce: Open "Manage Covers" and add at least 2 pictures
 

DrSquishy

we've all had better times to die
aa
Feb 10, 2017
1,251
Last edited:

nesman

master of fast travel
aa
Jun 27, 2016
898

Zeus

Not a Krusty Krab
aa
Oct 15, 2014
267
Old forums.tf2maps.net links do now redirect to the new site; the redirect isn't to the right location though. For example, with this link from pl_borax's download: http://forums.tf2maps.net/showthread.php?t=6356 - it redirects to https://tf2maps.net/home/?t=6356 instead of the actual thread, https://tf2maps.net/threads/6356.
this is simple to add to the webserver

could you provide me with all the old links you would expect to work and what it should redirect to?
I assume old downloads would need a simliar treatment?
 

DrSquishy

we've all had better times to die
aa
Feb 10, 2017
1,251
I don't remember this being a feature on the old site. Anytime I used one of the old links it would just not work at all.
It's a new feature yeah - it's now leading to the wrong position though

this is simple to add to the webserver

could you provide me with all the old links you would expect to work and what it should redirect to?
I assume old downloads would need a simliar treatment?
I think any thread follows the same rules mentioned in my first post. That is, going from forums.tf2maps.net/showthread.php?t=<id> to tf2maps.net/threads/<id>. As for downloads I remember having issues with /threads/<id> not pointing to the download page, but as of the site update they seem to point to the original download or map factory pages.

For example, the old download page link http://forums.tf2maps.net/showthread.php?t=15274 leads to https://tf2maps.net/home/?t=15274 while it should be pointing to https://tf2maps.net/threads/traction.15274/
As for post links, it's the same kind of thing - http://forums.tf2maps.net/showthread.php/?p=213727#post213727 leads to https://tf2maps.net/home/?p=213727#post213727 instead of https://tf2maps.net/posts/213727#post213727
 

Zeus

Not a Krusty Krab
aa
Oct 15, 2014
267
It's a new feature yeah - it's now leading to the wrong position though


I think any thread follows the same rules mentioned in my first post. That is, going from forums.tf2maps.net/showthread.php?t=<id> to tf2maps.net/threads/<id>. As for downloads I remember having issues with /threads/<id> not pointing to the download page, but as of the site update they seem to point to the original download or map factory pages.

For example, the old download page link http://forums.tf2maps.net/showthread.php?t=15274 leads to https://tf2maps.net/home/?t=15274 while it should be pointing to https://tf2maps.net/threads/traction.15274/
As for post links, it's the same kind of thing - http://forums.tf2maps.net/showthread.php/?p=213727#post213727 leads to https://tf2maps.net/home/?p=213727#post213727 instead of https://tf2maps.net/posts/213727#post213727

Both cases are working now.
Is there another one for downloads?

Code:
ServerName www.tf2maps.net
ServerAlias forums.tf2maps.net
ServerAlias archive.tf2maps.net

RewriteEngine on

RewriteCond %{QUERY_STRING} "^t=([0-9]+)" [NC]
RewriteRule "showthread\.php\/?/?" "https://tf2maps.net/threads/%1" [END,NE,R=permanent]

RewriteCond %{QUERY_STRING} "^p=([0-9]+)" [NC]
RewriteRule "showthread\.php\/?/?" "https://tf2maps.net/posts/%1" [END,NE,R=permanent]

RewriteCond %{HTTP_HOST} !^tf2maps.net$ [NC]
RewriteRule (.*) https://tf2maps.net/ [END,NE,R=permanent]

Edit: I tried doing the same for download links; but looks like something between then and now has shifted the ID's around. I dont have any way to dereference what the old -> new would be so those will remain broken unfortunately.

Example - This should go to TC Meridian:

That ID leads to
 
Last edited:

DrSquishy

we've all had better times to die
aa
Feb 10, 2017
1,251
Edit: I tried doing the same for download links; but looks like something between then and now has shifted the ID's around. I dont have any way to dereference what the old -> new would be so those will remain broken unfortunately.

Example - This should go to TC Meridian:

That ID leads to
Ah, that's the download page link issue I was thinking of. I couldn't find any examples while I was looking through old threads, so I assumed it was somehow fixed after the site migration.