Navigation mesh with bots crashes my game on my map

Discussion in 'Mapping Questions & Discussion' started by ThirdEye, Jul 14, 2019.

  1. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    One of my maps I am developing has a problem with the bots crashing the game after 5 minutes or so. I have no idea why because on my other map they seem to work fine.

    Any ideas to why this could be happening?

    I tried removing custom folder content which did nothing.

    Thank you!
     
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,123
    Positive Ratings:
    766
    -If you run the game for 5 (or so) minutes without bots, does the game crash?
    -Are there any errors in console?
    -Are there any errors in the compile log?
     
  3. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    -The game doesn't crash without bots.
    -Only errors I get:
    1) Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/sky_hydro_01dn)
    2) Attemped to precache unknown particle system "blood_impact_red"!
    However, I don't this this is the case as I get them without bots too.
    3) Compile log gives errors from the blend-grass on displacements, but that also isn't a problem as one of my other maps has tons the same error but works with bots.

    The only thing I know is that it is something wrong with this map only and not my game.
     
  4. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,123
    Positive Ratings:
    766
    If you get regular players on the map, does it crash?
     
  5. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    I have to setup the server download site for my map which will take too long. I am the player in the game so it shouldn't affect affect the crash, even if it does I need bots to work. I will try adding bots without the navigation mesh baked and see if they crash just standing there.
     
    Last edited: Jul 14, 2019
  6. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    It seems like the game doesn't crash on the map until there is either demomen or soldiers shooting explosives? I just had 9 pyros, 9 engineers no crash. Once I made the game normal and had the demomen rushing our last cp the game crashed.
     
  7. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,123
    Positive Ratings:
    766
    Do you have any power 4 displacements, or any displacements with high vertex density?
     
  8. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    All displacements on this map are with a power of 3 and no high vertex count.
     
  9. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1
    After more testing the game crash happens because of the bots navigation.
    -Without the navigation mesh generated on the map, it all works fine. But once it is generated and bots play it for around 5 mins the game crashes.
    -I have the crash happen often after the middle point has been capped.
     
  10. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,123
    Positive Ratings:
    766
    Can you post the BSP?
     
  11. ThirdEye

    ThirdEye L1: Registered

    Messages:
    25
    Positive Ratings:
    1