Water appears invisable

Discussion in 'Mapping Questions & Discussion' started by DrLinnerd, Aug 5, 2018.

  1. DrLinnerd

    DrLinnerd L1: Registered

    Messages:
    17
    Positive Ratings:
    0
  2. Startacker!

    aa Startacker! Dissociating in the Five Guy’s backroom

    Messages:
    625
    Positive Ratings:
    1,002
  3. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,335
    Positive Ratings:
    898
    It could just be that VVIS wasn't run. In order for water to render, the VVIS part of the compile process must be run in either fast or normal mode.
     
  4. FloofCollie

    aa FloofCollie I really suck!

    Messages:
    566
    Positive Ratings:
    540
    Make sure you're not using water from another game. Type "tf" into the keywords box.
    Also yay 3kliksphillip
     
    • Thanks Thanks x 1
  5. DrLinnerd

    DrLinnerd L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    while compiling the map I found this message:
    Water found with no water_lod_control entity, creating a default one.
    Compacting texture/material tables... would that cause issues?
     
  6. iiboharz

    aa iiboharz eternally tired

    Messages:
    822
    Positive Ratings:
    1,169
    It wouldn't cause any issues, no.

    Either you're using a texture that doesn't work, or you have a leak, as already stated.
     
    • Thanks Thanks x 1
    • Agree Agree x 1
  7. henke37

    aa henke37

    Messages:
    2,059
    Positive Ratings:
    501
    As the message says, vbsp took care of the situation for you. That's not the issue.
     
  8. DrLinnerd

    DrLinnerd L1: Registered

    Messages:
    17
    Positive Ratings:
    0
    Just had some leaks that needed to be patch, thanks for the help