Sounds embed into .bsp do not work on workshop

Discussion in 'Mapping Questions & Discussion' started by Rare Endangered Spycrab, Feb 2, 2018.

  1. Rare Endangered Spycrab

    Rare Endangered Spycrab L2: Junior Member

    Messages:
    97
    Positive Ratings:
    30
    All the sounds I have embed into the .bsp are not recognised at all when the map is used from the workshop. I think this might be related to the sound.caches that are not created, but I'm not too sure. Can anyone tell me what is the problem? Embed textures and models work fine. I'm using CompilePal, I tried using VIDE but it resulted in the same thing.
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Are you sure they are packed? You can check by opening the bsp with GCFScape.
     
  3. Rare Endangered Spycrab

    Rare Endangered Spycrab L2: Junior Member

    Messages:
    97
    Positive Ratings:
    30
    GCFScape says the Package type is unsupported, (I had the same issue with another map for CSS but all the embed content was working). However 7zip is able to open it, and yes, they are packed in
     
  4. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    Wasn't there an issue with the Workshop where certain types of assets wouldn't work? I recall them fixing one of the Workshop problems recently, but I think it was the one where you couldn't upload maps that you compressed yourself.
     
  5. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,843
    Positive Ratings:
    4,775
    This is a problem with the workshop. You cannot do anything about it.
     
    • Agree Agree x 1
  6. MOCOLONI

    MOCOLONI L5: Dapper Member

    Messages:
    243
    Positive Ratings:
    60
    Can't confirm anything, but wasn't there a way to fix embedded .NAV files? Perhaps using the same fix but with sound files could work.
     
  7. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    665
    Positive Ratings:
    471
    The fix was to rename them embed.nav.