I need some help with hammer

Discussion in 'Mapping Questions & Discussion' started by UnDead Lincoln, Oct 9, 2016.

  1. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    so I am new to hammer and I created a simple box in hammer. So then I go to run the map but then it said that the file specified could not be found. I'll show you it here

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\test_cool.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\test_cool.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."
     
  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    998
    Positive Ratings:
    1,135
    Can you provide the entire compile log, please? This doesn't tell us anything about why it failed.
     
  3. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    that is the entire compile log
     
  4. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,102
    Positive Ratings:
    5,982
    To check, you are running the compile in Hammer, not CompilePal or another program?

    Sorry if that seems a silly question - this is a unique issue!
     
  5. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I'm running it in hammer
     
  6. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    78
    Do you have "Run BSP" set to Normal in the menu you get before starting the compile?
     
  7. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I have the "Run BSP" set to normal
     
  8. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    78
    Are you using the version of hammer packaged with TF2 (at Team Fortress 2\bin\hammer.exe)?
     
  9. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Yes I'm using the version of hammer packaged with TF2
     
  10. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    78
  11. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    it says that 1 file failed to validate and will be reacquired. What does that mean?
     
  12. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    78
    It means that one of your files was broken and Steam downloaded a fresh copy. Try compiling with hammer now.
     
  13. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    It still doesn't work I got the same thing again
     
  14. Doktor Richter

    Doktor Richter L3: Member

    Messages:
    117
    Positive Ratings:
    78
    Have you been moving around or deleting VMF files while hammer was still open? That's the only way I can get it to happen on my end. Maybe try restarting everything (computer, steam, TF2, and hammer) and reloading your vmf?
     
  15. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,818
    Positive Ratings:
    4,660
    Can you please post a screenshot of your run map window because it appears the only command being run is the copy map one, and not the actual compile. This shouldn't be happening unless you are using expert compile mode.
     
    • Agree Agree x 1
  16. UnDead Lincoln

    UnDead Lincoln L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    First of all to answer your question:
    the run map window, everything is set to normal and the "Don't run the game after compiling" is not checked, and I'm didn't change anything in the Expert compile mode (and I didn't even use it)



    But I think I might know what is causing this to happen but I don't know how to fix it. When I went to boot up hammer it said that the game configurations had to be set manually. I'm positive that you can change that in the tools tab in hammer and go down into options. So I had to guess. For the game data files it said that they were .fgd files so I put 3 of the .fgd on that list which are halflife2,tf, and tf-abs which can be found in the Team Fortress 2 bin. Next it was asking for the "Game Executable Directory" and I just directed it to the Team Fortress 2 Folder. After that it was asking where the gameinfo.txt is and I located it and found it in the tf folder in the Team Fortress 2 Folder. Lastly it was asking for the "Hammer VMF Directory" and I just looked on UeakCrash's video and looked at where he directed his maps (because when your on hammer above the 3-D camera it shows where your map is being located to so I looked on UeakCrash's video and directed it to that folder which was \Team Fortress 2\sourcesdk_content\tf\mapsr)

    If there is anything wrong or something I need to changed please tell me I completely understand if I messed something up because I'm new at this. And keep note that I THINK that this is the problem, I don't know if it 100% is.
     

    Attached Files: