Grappling hooks...

Discussion in 'Mapping Questions & Discussion' started by DeOntwerper, Jan 15, 2015.

  1. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
    Heya there,

    I watched this tutorial and followed everything to the letter.

    However when I test it on my own map the grappling hook just goes straight through the trigger that is supposed to kill it.

    I've even deleted the stuff I created from the video and copied/pasted the filter and trigger from the example map he provides. It works on his example map...but with the exact same properties/values etc for the filter/trigger...it doesn't work on my own map.

    It's quite frustrating as I'm wanting some surfaces to be unhookable with the grappling hook.

    EDIT: Values/properties for trigger and filter...
    [​IMG]
     
    Last edited: Jan 15, 2015
  2. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
    Yeah...so helpful...:glare:
     
    • Thanks Thanks x 1
  3. radarhead

    aa radarhead Hands out ratings like cheap cigars

    Messages:
    1,004
    Positive Ratings:
    543
    Come on, bigbros.
     
  4. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
    I've tried everything to try and get it working...but it refuses to work even if I copy/paste it from the example map...
     
  5. Idolon

    aa Idolon the worst admin

    Messages:
    1,538
    Positive Ratings:
    4,417
    I've got a working setup, and the only difference I can see is that I'm using OnTrigger instead of OnStartTouch, and my Delay Before Reset is set to 0. It's also possible that the projectile is just going through the trigger because of a bug - I've found that thin triggers (as well as standing really close to the trigger) will sometimes let the projectile through. The best fix is to just make your trigger thicker.
     
  6. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Maybe the trigger has to cover the surface the hook is attaching to?
     
  7. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
    I've tried it OnTrigger inside my map...not working at all.

    However I set up my own little test map and it works fine. So I have literally no idea why it isn't working inside my own map.

    I have tried the trigger being outside of another trigger / touching each wall as well as setting the delay before reset to 0/0.001/1.

    I really don't know what's wrong. :(
     
    Last edited: Jan 26, 2015
  8. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
  9. Namieo

    Namieo L1: Registered

    Messages:
    23
    Positive Ratings:
    4
    I can't see the tutorial you're talking about (seeing as you appear to have pasted something that isn't even a link), but a while back I tried doing the same thing with OnStartTouch and a reset delay of 0. It worked from a distance, but up close, it had, hmm, issues. The entity setup you have looks pretty much like what I had, so the only thing I can think of would be how thick you made the trigger.

    If the tutorial you saw isn't affected by this, that would be pretty neat.
     
    Last edited: Jan 17, 2015
  10. DeOntwerper

    DeOntwerper L1: Registered

    Messages:
    46
    Positive Ratings:
    1
    Sorry, didn't realise I forgot to paste the link in the post >_<

    This is the tutorial: http://www.youtube.com/watch?v=yN6Slg2jBhk

    I've tried also removing the triggers around it so nothing is inside the trigger, only the walls touching the edges.

    :( This is rather annoying and probably means I need to copy all of the map to another new file :S

    EDIT: So I gave up trying to fix it and started to copy everything to a new map file... =/

    Also...I notice that bug as well...anyway to fix it?
     
    Last edited: Jan 18, 2015