TF2 Crashes on compile

Discussion in 'Mapping Questions & Discussion' started by Ober, Feb 28, 2017.

  1. Ober

    Ober L1: Registered

    Messages:
    18
    Positive Ratings:
    10
    Every time I compile my map, it runs TF2 normally, but when it would normally load the playable map, it does a black screen and crashes completely. I posted the compile log in a log checker, and it found 2 leaked props (even though they were completely inside the giant skybox I put around the map) and a "can't load skybox file skybox/sky_nightfall_01 to build the default cubemap!" message. After hiding the leaked props, the map still crashed. I don't know why it cannot load the skybox texture, it is in my files and on the TF2 sky list (https://developer.valvesoftware.com/wiki/Team_Fortress_2_Sky_List). Please help.
     
  2. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,597
    Positive Ratings:
    1,677
    The "can't load skybox file skybox/sky_nightfall_01 to build the default cubemap!" can safely be ignored.
    Fixing leaks is definitely a priority.
    tips on debugging funky leaks:
    -make sure the origin of whatever leaks is enclosed
    -func_detail, brush entities and displacements doesn't seal.
    -lol restart hammer
     
  3. Ober

    Ober L1: Registered

    Messages:
    18
    Positive Ratings:
    10
    I really don't understand why there would be leaks, I literally made a huge cube around the map and hollowed it.
     
  4. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,597
    Positive Ratings:
    1,677
    well, have you looked at your pointfile? what does that say?
     
  5. Ober

    Ober L1: Registered

    Messages:
    18
    Positive Ratings:
    10
    [​IMG]
    I loaded the pointfile, there is just a line inside the skybox. I'm not sure if this means anything, but it is close to the corner of the skybox.
     
  6. Micnax

    aa Micnax I maek map

    Messages:
    2,020
    Positive Ratings:
    1,338
    I see the map has a _d in the filename, which means it's decompiled, yeah? I've experienced problems like this after decompiling maps previously too and it's super weird. I forgot how I fixed it buit I had to rebuild a whole bunch of sections (areaportals mostly, they were all bugged). If you have any in your map I'd recommend re-making the areaportals manually.
     
    • Agree Agree x 1
  7. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,372
    Positive Ratings:
    4,167
    Also...
    This is ill-advised. Surrounding the map with a big hollow cube will cause various other issues, namely with optimisation. Have a look at this article.
     
  8. obodobear

    obodobear L4: Comfortable Member

    Messages:
    160
    Positive Ratings:
    27
    This is not really related to this, but I've wanted to ask about it. Recently whenever I compile my maps in hammer, when tf2 opens it does not go to full screen. Instead I have the bordered view like you would have in other programs. I have no idea what caused this to start happening but it can be a bit annoying at times. It does not mess up anything with tf2 or the map itself.
     
  9. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,419
    Positive Ratings:
    1,141
    Check your launch options.
    For the game to be fullscreen, you either need -fullscreen (real fullscreen; also afaik it defaults to it), or -windowed -noborder so it behaves like a usual window app but appears full-screen; it can be alt-tabbed from while loading, for instance.
     
    • Thanks Thanks x 1
  10. obodobear

    obodobear L4: Comfortable Member

    Messages:
    160
    Positive Ratings:
    27
    Cool, I'll try it out later today
     
  11. Basileus

    Basileus L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    I'm also having this issue.

    I just started getting into map making, so my map right now consists of a single room, only a floor, four walls, and a ceiling. I don't think that there would be a leak anywhere, since all the blocks are snapped to the grid and touching each other.

    I opened 'Check for Problems', under the 'Map' tab and it says that "there is no player start." even though I have three spawn point entities, all of which are floating off ground by 16 HU.

    Does anyone know what might be going wrong? I started a completely new map, with the same layout, and I still get this issue every time.
     
  12. Micnax

    aa Micnax I maek map

    Messages:
    2,020
    Positive Ratings:
    1,338
    That problem is caused by the map not having an info_playerstart spawn point, which isn't needed in TF2 because it uses info_player_teamspawn instead. It can safely be ignored.
     
  13. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,597
    Positive Ratings:
    1,677
    Well you need to have to make sure you have at least one entity in there, prop_static, team_control_point, anything. that's how vbsp is able to tell which part of your map is inside and what's outside
     
  14. Basileus

    Basileus L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Thanks for your help Micnax and fubarFX, I got everything to work now.