[SOLVED] Problem with lighting when adding skybox.. (TF2)

Discussion in 'Mapping Questions & Discussion' started by 123123unknownx, Jan 11, 2017.

  1. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    Yesterday I ran into a problem regarding the 2dskybox and the lighting in my map.
    The problem is that when i add a skybox to my map all of my light suddenly doesn't work (everything is black)
    removing the skybox resolves this issue, but I want my map to have a skybox.

    Note that I do not have any leaks in my compile log.
    ALT+P doesn't show any errors aswell.
     
  2. Nicky

    aa Nicky Rotten Tops

    Messages:
    906
    Positive Ratings:
    1,657
    Are you using the normal toolsskybox texture or the 2dskybox texture (the one that has "2D" in the middle of the texture)? Use the normal toolsskybox texture (the one that looks like this:
    :skybox:)
     
  3. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,321
    Positive Ratings:
    916
    Probably this. Have you used search on this site or with Google by chance?
     
  4. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    I originally used 2dskybox, switched to the normal toolsskybox didn't resolve the issue.
     
  5. Beef Bucket

    aa Beef Bucket L666: Brutal Member

    Messages:
    289
    Positive Ratings:
    369
    Do you have a light_environment anywhere in your map? This is a wild guess, but it could be your map is trying to pull from a light entity that doesn't exist which is messing the other lights up as well.
     
  6. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    Thanks, will try that. FYI, I have searched and tried alot before making a post.
     
  7. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    Yes, it does has a light_environment in the map.
     
  8. AsG_Alligator

    aa AsG_Alligator trigger_hiss

    Messages:
    304
    Positive Ratings:
    681
    Is your map origin inside a brush?
     
  9. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    nothing is inside my map origin.
     
  10. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,321
    Positive Ratings:
    916
    What about light entities?
     
  11. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    update: It doesn't seem like that I have any light source inside a world brush.
     
  12. AsG_Alligator

    aa AsG_Alligator trigger_hiss

    Messages:
    304
    Positive Ratings:
    681
    Is everything dark? Brushes and models?
     
  13. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    [​IMG]
    this is how it looks ingame.
    everything around it is black. (ammo packs/health packs are visible too, aswell as water).
    *this problem did not persist in older versions of my map.
     
    Last edited: Jan 11, 2017
  14. AsG_Alligator

    aa AsG_Alligator trigger_hiss

    Messages:
    304
    Positive Ratings:
    681
    So models are lit, brushes are black.

    I'm pretty sure this is what happens when map origin (0,0,0 point on hammer grid) is embedded within a world brush.
     
  15. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    [​IMG]
    this is from Hammer. I don't see anything wrong with it
     
    • Funny Funny x 1
  16. Blade x64

    aa Blade x64 Logical insanity

    Messages:
    196
    Positive Ratings:
    427
    Your 3d sky is likely casting a shadow onto the main map. Ensure the imaginary area the main map occupies in the 3d sky is free of shadow casting objects.
     
  17. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    what do you mean exactly?
     
  18. basilhs333

    basilhs333 L7: Fancy Member

    Messages:
    474
    Positive Ratings:
    88
    it depents,
    if your skybox is completed and there are no leaks or you messes up the light environment.
    if you have the same problem i had with my map on the one day everything is all right but suddently the whole map is black, what i did is just move the whole map a bit , when i did that i saved the map as too with a different name just to be sure for exable pl_test_a1 i changed it to pl_test_a2
    try those , if you still dont get the problem fixed i dont quite now what you should do
     
  19. 123123unknownx

    123123unknownx L1: Registered

    Messages:
    45
    Positive Ratings:
    2
    Tried moving the map, didn't work.
     
  20. basilhs333

    basilhs333 L7: Fancy Member

    Messages:
    474
    Positive Ratings:
    88
    maybe you have a light into a brush?
    dunno to be honest . if i were you i would probably copy and paste the map into another new empty map
     
    • Funny Funny x 1