Skyboxes never cooperate

Discussion in 'Mapping Questions & Discussion' started by ★ Conga ★, Sep 2, 2017.

  1. ★ Conga ★

    ★ Conga ★ L1: Registered

    Messages:
    21
    Positive Ratings:
    13
    So i've been trying to implement a very important map feature for a while now without any success, i've tried following tutorials exactly, i've tried recompiling decompiled valve maps and even my own things, disabling HDR, Enabling it, but, they never cooperate~
    I'm starting to feel like it's a setting I have with hammer which is doing this, because they should logically be working~

    Any suggestions on how to fix it~?
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Unfortunately, not a single member of tf2maps is telepathic. How are we suppose to help you, when you don't tell us what you want to do and what you were doing??

    Tell us what you are trying to do. Change skybox texture? make a custom skybox texture? Make a 3D skybox?
     
    • Agree Agree x 1
    • Funny Funny x 1
  3. ★ Conga ★

    ★ Conga ★ L1: Registered

    Messages:
    21
    Positive Ratings:
    13
    I was just trying to implement a skybox into my hammer level and compile it, simple as that~
    Nothing else, it just refuses to work and the skybox acts the exact same as if there were no skybox at all except for a few points where I look in certain angles, then it works but only until I leave that angle~
     
  4. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    663
    Positive Ratings:
    468
    Did you surround your level in a toolsskybox texture?
     
  5. ★ Conga ★

    ★ Conga ★ L1: Registered

    Messages:
    21
    Positive Ratings:
    13
    Yes, i've even tried recompiling a valve map and I still have this issue
     
  6. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
    Yeah, well, the decompile process doesn't spit out a perfect VMF that you can just recompile and have the same BSP you had before the decompile. Your skybox is likely not the cause of your issues, something else is. Do you have any invalid solids or leaks or other compiler breaking stuff happening? Check alt+p (the Hammer error checker) for invalid solids and if it finds any, remake them so they're not concave (a brush can't have concave faces). Then check for leaks as they also stop a compile from properly finishing. Post your compile log in this compile log checker: http://www.interlopers.net/errors?page=errors&params= . If anything's wrong it'll tell you and how to fix it.

    Or get the .exe to make it do it for you while you compiler runs (this does require a bit of setup but it comes with a setup and user guide) here.
     
    • Thanks Thanks x 1
  7. ★ Conga ★

    ★ Conga ★ L1: Registered

    Messages:
    21
    Positive Ratings:
    13
    Aha, thankyou, i'll try using the error checkers you gave me to try and fix up things, i'll tell you how it goes when i'm done~

    EDIT: After two and a half hours of work, my skybox works A-ok, thankyou for this~!
     
    Last edited: Sep 3, 2017
Tags: