Resource Pack Errors (Solved)

Discussion in 'Mapping Questions & Discussion' started by Sailaser, Jul 6, 2019.

  1. Sailaser

    Sailaser L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    Hi, I just installed the Japan Resource Pack into my custom folder by following the readme text file in its folder and when I try to view the .vmf props map, all the props show up as errors. Is there a fix for this?
     

    Attached Files:

  2. Narpas

    aa Narpas Takes way to long to make and update maps

    Messages:
    428
    Positive Ratings:
    407
    In order for the game to know that you've installed the custom assets to your tf\custom folder, you need to run the game first, then Hammer and other tools will be able to pick up the content. So, simply run TF2 and then exit out, and that should fix your problem
     
  3. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,312
    Positive Ratings:
    866
    Hammer is capable of discovering custom content on its own, you dont need to launch TF2 for that. However, Hammer only searches for custom content once, at startup. When you install new content, you must exit Hammer (and TF2, if you have that open) and then relaunch.
     
  4. Sailaser

    Sailaser L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    I've tried both, and the props still show up as errors.
     
  5. Narpas

    aa Narpas Takes way to long to make and update maps

    Messages:
    428
    Positive Ratings:
    407
    Can you show us a screenshot of your tf\custom folder? Make sure it contains a folder named something like "JapanContentPack_1.1", and that folder contains the folders "maps", "materials", "models", and "particles", or something like that
     
  6. Sailaser

    Sailaser L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    here's both the custom and new folder where the pack was extracted to
     

    Attached Files:

  7. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,312
    Positive Ratings:
    866
    The second screenshot should have "materials" and "models" folders. I assume those are nested within the "Japan Content pack 1.1" folder, which is why Hammer can't find them. Move all of the items in the "Japan Content pack 1.1" folder one level up.
     
    • Agree Agree x 1
  8. Sailaser

    Sailaser L1: Registered

    Messages:
    20
    Positive Ratings:
    1
    Props are now visible. Thanks a ton, I appreciate it!
     

    Attached Files: