Nodraw Areaportals

Discussion in 'Mapping Questions & Discussion' started by cadeonehalf, Feb 18, 2010.

  1. cadeonehalf

    cadeonehalf L1: Registered

    Messages:
    32
    Positive Ratings:
    6
    I'm attempting to optimize my map ctf_geneseefalls, but all of my func_areaportals are rendering with the same effect as a visible nodraw surface- that kind of tunnel look. They open once I run through them, but I have the func_areaportal set to initial state open, so this problem shouldn't even arise.

    After searching this forum, I gather most of the time that's due to leaks. Problem is, my map no longer generates a pointfile when compiling, so I'm certain there aren't any leaks. What else can cause this problem?
     
  2. Micnax

    aa Micnax I maek map

    Messages:
    2,045
    Positive Ratings:
    1,370
    They're probably not connecting correctly, or they're clipping through a brush or func_detail

    Post your compile log :D
     
  3. Cynick

    Cynick L4: Comfortable Member

    Messages:
    153
    Positive Ratings:
    144
    Maybe a dumb question, but: you are using the areaportal texture on ALL faces of the brush, correct?

    If so, like Joodude said it's probably an areaportal clipping issue of some kind.

    EDIT: Also, make sure your areaportals are only one brush per areaportal entity.
     
    Last edited: Feb 18, 2010
  4. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    I smell an (areaportal) leak.
     
    • Thanks Thanks x 1
  5. megawac

    megawac L4: Comfortable Member

    Messages:
    180
    Positive Ratings:
    29
    The area portals arent set to closed are they?
     
  6. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    That would still generate a pointfile.
     
  7. Boylee

    aa Boylee pew pew pew

    Messages:
    1,068
    Positive Ratings:
    631
    Two brushes tied to the same func_areaportal entity?
    Need compile log for conclusive diagnosis.
     
  8. Micnax

    aa Micnax I maek map

    Messages:
    2,045
    Positive Ratings:
    1,370
    Oh, and make sure it's actually tied to an func_areaportal entity, a mistake I made a while back.
     
  9. Xi.Cynx

    aa Xi.Cynx Former Alias: †Blade†

    Messages:
    772
    Positive Ratings:
    722
    Another thing to keep in mind is: Don't make all the brushes for all the areaportals and then select them all and alt+enter = fun_areaportal that's not good. You have to make each brush it's own func_areaportal and then you can "group" them after you have made each individual portal.

    But yea, if you didn't do that then either A) an areaportal has coming back around to touch itself, which in this case you would want to create a pointfile via the option menu in hammer. Or B) ... ... umm... it's either the initial point or point A! erm...