Increase Hammer Editor's speed?

Discussion in 'Mapping Questions & Discussion' started by Bull, Jan 15, 2015.

  1. Bull

    Bull L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    140
    Hey guys,

    I've been having some trouble with Hammer. I don't know it's because my map is just huge or something but my editor gets really slow over time. I can still build / navigate fine in hammer but applying a texture / tieing a brush to an entity freezes hammer for about a second or 2. This is really frustating and I hope you guys can help me out here.

    As a note, I'm using quite a bit of func_details where-ever possible. My 3d drawing distance / model detail distance is quite a low as well.

    Pc specs:
    Processor: AMD Quad Core 3,7 GHZ
    Graphics card: Nvidea Geforce GTX 780
    RAM: 16 GB RAM

    Here's an album of my Hammer editor, with my last map opened.
     
  2. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    172
    I'd like to know if there's anything I can do about this as well. Same exact performance problems.
     
    • Thanks Thanks x 1
  3. iiboharz

    aa iiboharz Meme Queen

    Messages:
    701
    Positive Ratings:
    1,029
    Your specs seem quite alright, I have similar specs and I've never run into something like this, even when I had worse specs.
     
    • Thanks Thanks x 1
  4. Crash

    aa Crash func_nerd

    Messages:
    3,132
    Positive Ratings:
    4,712
    Yeah, I have worse specs now and don't have issues like that. It gets a little bogged down on large fully detailed maps, little choppy when flying around, but not horrible. It only gets bad when I'm trying to manipulate a large amount of things at once, like flipping a map or something.
     
    • Thanks Thanks x 1
  5. iiboharz

    aa iiboharz Meme Queen

    Messages:
    701
    Positive Ratings:
    1,029
    Yeah pretty much the same here - something must be hogging CPU or memory or something.

    If it does turn out to be your hardware at all, switch away from that nasty AMD CPU.
     
    • Thanks Thanks x 1
  6. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Best thing I know to fix this is to just use Cordon more often. Only have what you are working on active
     
    • Thanks Thanks x 2
  7. Lampenpam

    aa Lampenpam

    Messages:
    1,018
    Positive Ratings:
    337
    and disable radius culling, it might look like it's exist to render less but it breaks down the frame rate.

    Is there even any good reason to turn on radius culling? To me it was always a laggy cordon tool which just leaks when compiling
     
    • Thanks Thanks x 1
  8. Bull

    Bull L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    140
    Right, not really sure what it is. Posted to Reddit as well, got some good tips from there.

    Also I'm thinking of a CPU upgrade, my motherboard's limited to AM2 / AM3 so I'm probably going for another AMD. A way quicker one though.

    Hot damn I've been mapping for years but never looked into this tool! Thanks!

    Radius Culling is off!
     
  9. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,372
    Positive Ratings:
    4,174
    I keep accidentally switching it on without realising sometimes. And then I wonder why my compiles are getting all fucked up.
     
    • Thanks Thanks x 2
  10. ics

    aa ics http://ics-base.net

    Messages:
    662
    Positive Ratings:
    412
    Check that C key isn't pressed. Also you can toggle visibility by pressing 1 multiple times and 2 to the other way.
     
    • Thanks Thanks x 1