Water

Discussion in 'Mapping Questions & Discussion' started by Cameron:D, Oct 9, 2008.

  1. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    Yeah, I know how to create water... But I'm wondering why the water looks like the attached pic, with the ugly blue reflection. I've used the same type of water on another map with normal results. (water/water_well).

    Any suggestions?
     
  2. jabster

    jabster L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Um what entities have you added, and what class do you have on the water brush
     
  3. toutfou

    toutfou L3: Member

    Messages:
    136
    Positive Ratings:
    16
    Where is your env_cubemap placed? Make sure one is placed just above the surface to get the best reflection results.
     
  4. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    The water is not tied to any entity and there is a lod manager and cubemap right above the surface
     
  5. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    The rest of faces are nodraw?
     
  6. Username

    Username L2: Junior Member

    Messages:
    96
    Positive Ratings:
    53
    Could the lod controller be borked? Looks like cheap water to me.
     
  7. Laz

    Laz L7: Fancy Member

    Messages:
    461
    Positive Ratings:
    34
    perhaps u used the wrong texture. Expiriment with others.
     
  8. Gadget

    aa Gadget

    Messages:
    495
    Positive Ratings:
    411
    really strange. Try to scale the water to 1.00 and post your waterlodcontroller properties, please. Did you set the cubemap's face to the water face and do you have any lights with such a blue color near the water?
     
  9. Earl

    Earl L6: Sharp Member

    Messages:
    284
    Positive Ratings:
    37
    Does your map have a leak?
     
  10. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    Yes the rest of the faces are nodraw.

    It is cheap water, I only have DX 8. I'll check what it looks like with a higher version when I can get my dads lappy ;)

    I've used this water texture before with no problems.

    I'll change the scale and recompile later, the water_lod_control's settings are all default. The cubemap's face has been set to the water, I was just thinking earlier on that it could be the sun doing it - the sun's ambient colour is set to a blue shade.

    Nope, no leak as VVIS and VRAD ran, and nothing about one in the compile log.
     
  11. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    you wouldn´t even see the water if you had a leak... wondered why i couldn´t see mine, until i fixed a leak :)

    it could be indeed the shadows, they react pretty hefty, i only change them by minimum if neccessary
     
  12. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    Try to make tf2 settings higher, check if u somehow dled custom texture with that name.
     
  13. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    I run with everything up max when testing maps, but DX8 has little support for real time reflections, so it won't make a difference
     
  14. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    OK, I've managed to get on my dads lappy and test the map, and the water was making all those silly purple/black checks reflections.
    I'm getting those reflections ONLY on my brushes. Entities and weapons reflect fine, so what do I need to do to fix that? (I've got all my env_cubemaps, and I built all my cubemaps, with no fix).
     
  15. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    If I had a leak, then VVIS and VRAD would not run, and they do - and I've run the compile log through the log checker with the only thing being that one about the sky not being compiled with the same flags.
     
  16. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    U've built ur cubemaps incorrectly or alt+tabbed tf2.
     
  17. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    a)How do I go about making the cubemaps 'correctly'?
    b)I never really alt-tab TF2.
     
  18. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
  19. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
  20. Psyphil

    Psyphil L3: Member

    Messages:
    125
    Positive Ratings:
    30
    after u have buildcubemaps u have to restart the server or atleast changelevel for it to take effect, sometimes restarting the game is required too