running map doesnt update it (fixed)

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
I've recently reworked a large chunk of my map and when I go to see if everything is looking right and to check what needs to be tweaked I enter the map in tf2 to find the area still like it was before I started to fix it.

I know the new file trick, but I want to know if theres a way to fix it.
 

WillWow_mc

L2: Junior Member
Nov 29, 2014
51
Well are you sure that you've got no errors during compile? All I can think of is the times for me when that happened, and it was due to a failure in the compile process that was a bit harder to spot. Compile without VIS and RAD to make it a lot quicker when checking, because I think VIS and RAD still are done on the last compiled version of the map if it's still there, so it might not appear to be failing compile.
 

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
Well are you sure that you've got no errors during compile? All I can think of is the times for me when that happened, and it was due to a failure in the compile process that was a bit harder to spot. Compile without VIS and RAD to make it a lot quicker when checking, because I think VIS and RAD still are done on the last compiled version of the map if it's still there, so it might not appear to be failing compile.
I copied the log to notepad and looked for error and got no results back, what would constitute an error without saying error?
 

VEssex

L2: Junior Member
May 19, 2016
76
Try deleting the map and seeing if compiling places a .bsp in the maps folder. If it doesn't, I suggest restarting hammer or/and/then the computer.
 

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
lets see if there is a character limit:



** Executing...
** Command: "E:\SteamLibrary\steamapps\common\team fortress 2\bin\vbsp.exe"
** Parameters: -game "E:\SteamLibrary\steamapps\common\team fortress 2\tf" "C:\Users\Admin\Desktop\TF2 maps\pl_snowed_in_a8.vmf"
Valve Software - vbsp.exe (Oct 14 2017)
8 threads
materialPath: E:\SteamLibrary\steamapps\common\team fortress 2\tf\materials
Loading C:\Users\Admin\Desktop\TF2 maps\pl_snowed_in_a8.vmf
Patching WVT material: maps/pl_snowed_in_a8/dev/dev_blendmeasure_wvt_patch
Patching WVT material: maps/pl_snowed_in_a8/dev/dev_blendmeasure2_wvt_patch
Patching WVT material: maps/pl_snowed_in_a8/pl_barnblitz/blendsnowtodirt001_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
**** leaked ****
Entity prop_static (-560.00 -96.00 40.00) leaked!
FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (512.0 0.0 264.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (512.0 0.0 -120.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (56.0 0.0 552.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (544.0 0.0 552.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (24.0 0.0 552.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 376.0 168.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 248.0 368.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:

FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 504.0 368.0)
Leaf 0 contents: CONTENTS_SOLID
Leaf 1 contents:
viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
Candidate brush IDs:
*** Suppressing further FindPortalSide errors.... ***
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...Bad detail brush side

** Executing...
** Command: "E:\SteamLibrary\steamapps\common\team fortress 2\bin\vvis.exe"
** Parameters: -game "E:\SteamLibrary\steamapps\common\team fortress 2\tf" "C:\Users\Admin\Desktop\TF2 maps\pl_snowed_in_a8"
Valve Software - vvis.exe (Oct 14 2017)
8 threads
reading c:\users\admin\desktop\tf2 maps\pl_snowed_in_a8.bsp
reading c:\users\admin\desktop\tf2 maps\pl_snowed_in_a8.prt
LoadPortals: couldn't read c:\users\admin\desktop\tf2 maps\pl_snowed_in_a8.prt

** Executing...
** Command: "E:\SteamLibrary\steamapps\common\team fortress 2\bin\vrad.exe"
** Parameters: -game "E:\SteamLibrary\steamapps\common\team fortress 2\tf" "C:\Users\Admin\Desktop\TF2 maps\pl_snowed_in_a8"
Valve Software - vrad.exe SSE (Oct 14 2017)
Valve Radiosity Simulator
8 threads
[Reading texlights from 'lights.rad']
unknown light specifier type - lights
[56 texlights parsed from 'lights.rad']
Loading c:\users\admin\desktop\tf2 maps\pl_snowed_in_a8.bsp
No vis information, direct lighting only.
Setting up ray-trace acceleration structure... Done (0.36 seconds)
3877 faces
769291 square feet [110777952.00 square inches]
1 Displacements
3374 Square Feet [485982.44 Square Inches]
sun extent from map=0.173648
84 direct lights
BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (10)
Build Patch/Sample Hash Table(s).....Done<0.0096 sec>
FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (1)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (8)
Writing leaf ambient...done
Ready to Finish
Object names Objects/Maxobjs Memory / Maxmem Fullness
------------ --------------- --------------- --------
models 13/1024 624/49152 ( 1.3%)
brushes 688/8192 8256/98304 ( 8.4%)
brushsides 4389/65536 35112/524288 ( 6.7%)
planes 1250/65536 25000/1310720 ( 1.9%)
vertexes 5228/65536 62736/786432 ( 8.0%)
nodes 2682/65536 85824/2097152 ( 4.1%)
texinfos 293/12288 21096/884736 ( 2.4%)
texdata 31/2048 992/65536 ( 1.5%)
dispinfos 1/0 176/0 ( 0.0%)
disp_verts 289/0 5780/0 ( 0.0%)
disp_tris 512/0 1024/0 ( 0.0%)
disp_lmsamples 9333/0 9333/0 ( 0.0%)
faces 3877/65536 217112/3670016 ( 5.9%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 2213/65536 123928/3670016 ( 3.4%)
leaves 2696/65536 86272/2097152 ( 4.1%)
leaffaces 4372/65536 8744/131072 ( 6.7%)
leafbrushes 1312/65536 2624/131072 ( 2.0%)
areas 2/256 16/2048 ( 0.8%)
surfedges 27015/512000 108060/2048000 ( 5.3%)
edges 15379/256000 61516/1024000 ( 6.0%)
LDR worldlights 84/8192 7392/720896 ( 1.0%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 360/32768 3600/327680 ( 1.1%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 5526/65536 11052/131072 ( 8.4%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 3/512 1056/180224 ( 0.6%)
LDR lightdata [variable] 1959964/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 0/16777216 ( 0.0%)
entdata [variable] 40475/393216 (10.3%)
LDR ambient table 2696/65536 10784/262144 ( 4.1%)
HDR ambient table 2696/65536 10784/262144 ( 4.1%)
LDR leaf ambient 16794/65536 470232/1835008 (25.6%)
HDR leaf ambient 2696/65536 75488/1835008 ( 4.1%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/9656 ( 0.0%)
pakfile [variable] 1946/0 ( 0.0%)
physics [variable] 302355/4194304 ( 7.2%)
physics terrain [variable] 0/1048576 ( 0.0%)
Level flags = 0
Total triangle count: 10422
Writing c:\users\admin\desktop\tf2 maps\pl_snowed_in_a8.bsp
19 seconds elapsed
-2.337347 -1.299201 0.000000
-2.337347 -1.278825 0.000000
2.063540 1.299201 0.000000
-2.337347 1.299201 0.000000
make_triangles:calc_triangle_representation: Cannot convert
** Executing...
** Command: Copy File
** Parameters: "C:\Users\Admin\Desktop\TF2 maps\pl_snowed_in_a8.bsp" "E:\SteamLibrary\steamapps\common\team fortress 2\tf\maps\pl_snowed_in_a8.bsp"

** Executing...
** Command: "E:\SteamLibrary\steamapps\common\team fortress 2\hl2.exe"
** Parameters: -game "E:\SteamLibrary\steamapps\common\team fortress 2\tf" -hijack +map "pl_snowed_in_a8" -steam


I got some feedback from interloper and I'm looking into them but extra eyes never hurt
 

WillWow_mc

L2: Junior Member
Nov 29, 2014
51
Well firstly you have a leak, that much is clear. I don't know how you didn't see that one :p
Go to Map > Load Pointfile, and then fly around in 3D view and find the red line coming out of your map somewhere, trace the red line and you'll be able to find the hole in your map. Unless you've not even sealed the whole thing at all and it's a huge hole into the void, in that case I'd say at least use the cordon tool for testing stuff before it's all sealed (though seeing the thing says 'a8' I'd assume it's not supposed to be unfinished with a big hole because stuff's not built yet).
 

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
the a8 is just there because this is the 8th rego at this. i'll probably use a1 when submitting the bsp. and yes, I have a whole chunk of area unsealed while I'm doing a lot of big changes. I am wondering about the other 2 errors
 

WillWow_mc

L2: Junior Member
Nov 29, 2014
51
Ah, I see. Well you'll want to use the cordon tool because that's what it's for I guess
I know another one of the errors is that you have a really big brush that crosses over a few visleaves I'm pretty sure. It's not the biggest deal when you're just checking stuff.
And apparently 'bad detail brush side', I'm not too sure about what that is but I'll assume it might be to do with func_details? Also try Map > Check for Problems, that might allow you to easier find this bad detail brush side.
 
Last edited:

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
any chance a skybrush box would do that?
 

WillWow_mc

L2: Junior Member
Nov 29, 2014
51
Possibly, all I know is that warning happened with one of my maps once, and it didn't really go away (I never tweaked the skybox or so) but it never impacted anything major.

(I added a little more to my last post just editing it now by the way, just so you don't miss it)
 

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
okay... so I put in some greenery outside the playable area is prop details. let me change them and see what happens
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
A leak alone does not cause a compile to fail; it is entirely possible to compile and run a map with a leak in it (although you should never release a map with a leak in it). The problem seems to be that VBSP is not finishing due to this error:
Find Visible Detail Sides...Bad detail brush side
This is what Interlopers says about the error:
Anonymous said:
find visible detail sides...bad detail brush side

Description:

The cause for this error is using multiple (incompatible) tool-textures on the same brush, or so it seems.
Apart from HINT and SKIP there aren't much combination of tool-textures allowed on the same brush, so any other combination is a possible cause. Tool-textures are the 'tools/' textures you can find using the texture browser in Hammer, and that have a special meaning.

Solution:
You will need to find the brush(es) with these tool-textures and replace those textures. The easiest way to find the source of the error is to hide all visgroups except for the visgroups which are for tools textures and then just look around the map in 3d textured mode.

See also:
WIKI: Tool textures

This error will cause your map to fail compiling completely
 
Last edited:

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
just flew through and I think I got them all, well I didn't. any hints on what I should look for
 

MoonFox

L10: Glamorous Member
Mar 17, 2015
739
I figured it out
I forgot to switch back to nodraw on a glass ceiling that used to be only clip brushes