props are black, no leak

Discussion in 'Mapping Questions & Discussion' started by Twist.vmf, Jun 12, 2017.

  1. Twist.vmf

    Twist.vmf L6: Sharp Member

    Messages:
    361
    Positive Ratings:
    132
    i have no idea what this is, nothing on the map is doing this. i tried disabling shadows but it did not work :/
    20170612132149_1.jpg
     
  2. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    356
    Positive Ratings:
    267
    If you're not compiling in expert mode, prop_statics get their lighting information from their origin point. You can however use an info_lighting entity to work as an external origin point for lighting purposes. Simply create an info_lighting entity near the prop, however not inside world geometry. Name it, and then set the "light origin" keyvalue in the prop_static to the name of the info_lighting.
     
    • Thanks Thanks x 1
  3. Twist.vmf

    Twist.vmf L6: Sharp Member

    Messages:
    361
    Positive Ratings:
    132
    what is expert mode?
     
  4. Erk

    aa Erk erk

    Messages:
    285
    Positive Ratings:
    643
    • Thanks Thanks x 1
    • Like Like x 1
  5. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    356
    Positive Ratings:
    267
    Expert mode is accessed by clicking the "Expert" button in the run map window. It allows you to type in advanced command line options (since all the compile tools are actually command line programs). These options allow you to compile your map with exact lighting on static props, and you should definitively use this when making the final release of your map. Just keep in mind that this is very slow and you should only use this for release compiles.
     
    • Thanks Thanks x 1