October 30 - SDK Update and Bug Fixes

Discussion in 'Mapping Questions & Discussion' started by tyler, Oct 30, 2012.

  1. Shanghai

    Shanghai L6: Sharp Member

    Messages:
    394
    Positive Ratings:
    383
    Yeah. Now none of mine have the cursor adjusting normally.
     
  2. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    287
    I lied and started mapping again... but wow this cursor bug is annoying as shit.
     
  3. GPuzzle

    GPuzzle L9: Fashionable Member

    Messages:
    638
    Positive Ratings:
    200
    Oh hey look you've got 666 posts. And agreed, the cursor bug is bugging me.
     
  4. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    500
    Cursor never worked properly for me due to some quirk interfacing with my video card, so it's business as usual on my end.

    Along with the lovely shimmering overlays.
     
  5. tyler

    aa tyler

    Messages:
    5,095
    Positive Ratings:
    4,591
    Shimmering overlays are a byproduct of Shaded Textured mode. Put it on normal Textured and they are fine.
     
  6. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    500
    Yeah I know.. but it looks so bad without the shading and I lose all sense of depth.

    So I just live with it, like a big wimp.
     
  7. tyler

    aa tyler

    Messages:
    5,095
    Positive Ratings:
    4,591
    On the contrary, I think the shaded preview is so miserable I frequently lose track of whether or not I'm using it unless I see overlays.
     
    • Thanks Thanks x 1
  8. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,437
    Positive Ratings:
    3,780
    Yea, regular textured mode still retains geometric shading, it just takes a little getting used to for people who have poor 3D perception. I suppose mostly it's personal preference, but most experienced mappers will use regular textured mode so the level is more legible; just like turning tools texture off in the visgroup.

    Perhaps this will be something you find out as you use the editor more and come to make changes in your work flow to improve speed/efficiency.
     
  9. Little Dude

    Little Dude L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    54
    Anyone else getting a really weird vrad error? My vrad seems to take forever to build vis leafs; even on fast mode. This occurred before this update and the TF2 halloween update. Anyone know a fix?
     
  10. Burnout6010

    Burnout6010 L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    65
    For me it seems to take less than half a sec on DualMove, even thought there are lots of rounded geometry. Make sure to have proper func_detail's
     
  11. Little Dude

    Little Dude L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    54
    For those who are having problems with the cursor not showing if you've selected a side to vertex manipulate (or any other cursor changing operation), simply open the map, then close it and reopen it. The cursor should change as it used to before the update