Displacement error

Discussion in 'Mapping Questions & Discussion' started by Gabriel378, Apr 4, 2016.

  1. Gabriel378

    Gabriel378 L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Hi everyone , i am a new user, probably this is not the right place to write, so excuse me ... I'm making a pretty cool map, but when i compile it, this is the log:

    ----------------------------------------------------------------------------------------------------------------------------------------
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Users\ASUS\Desktop\prova\Prova2.vmf
    Error: displacement found on a(n) func_detail entity - not supported (entity 8, brush 0)


    4 threads
    reading c:\users\asus\desktop\prova\Prova2.bsp
    Error opening c:\users\asus\desktop\prova\Prova2.bsp


    [Reading texlights from 'lights.rad']
    [56 texlights parsed from 'lights.rad']

    Loading c:\users\asus\desktop\prova\Prova2.bsp
    Error opening c:\users\asus\desktop\prova\Prova2.bsp
    ----------------------------------------------------------------------------------------------------------------------------------------

    If i "Destroy" the displacement, it's not giving error, but every texture i try to change won't solve the problem
    Error: displacement found on a(n) func_detail entity - not supported (entity 8, brush 0)

    This, as you can see, won't let me compile as well ... Is there any way to solve this ?
    Thanks.

    (If this is the wrong place to write, could you tell me where is it ?)
     
  2. DrLambda

    aa DrLambda L69: Teeheehee, Member

    Messages:
    458
    Positive Ratings:
    454
    You can't have a displacement inside a func_detail, it needs to be a world brush, or you will get an compile error. A displacement behaves like a func_detail for most vis purposes anyway, so simply change it to a world brush and everything will be fine.
     
  3. Gabriel378

    Gabriel378 L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Wow, it worked, thank you so much ;)