All brushes refuse to be lit

Discussion in 'Mapping Questions & Discussion' started by Sel, Nov 23, 2012.

  1. Sel

    Sel Banned

    Messages:
    1,241
    Positive Ratings:
    1,119
    Bolded the parts that look relevant to me.

    No idea what I did, considering the only changes I made was throw around some vents and brushes, and clone some lights, but suddenly VRAD makes the entire map black, meanwhile fast VRAD appears to work normally.

    I've tried removing the changes, but nothing works, and the map looks like this now.

    [​IMG]

    the fuck happened, help me tf2m hotline
     
  2. Dïcecübe

    Dïcecübe L3: Member

    Messages:
    114
    Positive Ratings:
    31
    Try with the '-final'. It may take a bit time but I think it's worth it.

    Also look at the portals... These numbers look way too much for me.

    Btw. High numbers of light bounces are normal since you got alots of lights.
    But these negative RGB's seems to a part of the problem.

    Why not try to convert some of the detail brushes to func_detail?
     
    Last edited: Nov 23, 2012
  3. Sel

    Sel Banned

    Messages:
    1,241
    Positive Ratings:
    1,119
    Probably caused by fast vis

    They're not normal, the previous builds had 15 light bounces, then suddenly it started doing 100 with negative light.

    Almost everything that should be func_detailed is func_detailed.
     
  4. Dïcecübe

    Dïcecübe L3: Member

    Messages:
    114
    Positive Ratings:
    31
    Hmmm... I don't know what's causing problems like that.

    But try everything on 'normal' with -final in the addtional parameters.
     
  5. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    One time this happened to me and it was because I put some lights in a brush on accident. Another time, restarting steam fixed it. What does Interlopers say?

    Running - final won't change anything.
     
    • Thanks Thanks x 1
    Last edited by a moderator: Nov 23, 2012
  6. fubarFX

    aa fubarFX The "raw" in "nodraw"

    Messages:
    1,605
    Positive Ratings:
    1,696
    so... what happens if you hide all lights but env_light?

    this make me wonder, what happens if you input negative values in light ents? did you do that by mistake?
     
  7. Sel

    Sel Banned

    Messages:
    1,241
    Positive Ratings:
    1,119
    the culprit, the bottom of this brush was touching the floor, makes perfect sense that would then cause all the light to be sucked out of the map!

    [​IMG]
     
    • Thanks Thanks x 3
  8. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
  9. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    Another source of this problem is if you have too high of a light density in an area (also caused by texlights usually).
     
  10. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,561
    What Booj said, i got this problem once and it was because i had a high value grid (4 or 8) lightmap scale on a texlight. Each luxel (lightmap square) counts towards your light limit. You might have just inadvertantly brought your light count under the limit by reducing its (the face in question) size. So double check its lightmap scale.

    Unless i'm translating it wrong and it has nothing to do with the limit, but just a density issue like Booj suggested first.
     
  11. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    It is in fact a density issue, when I had it I wasn't anywhere near the limit.
     
  12. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    724
    Positive Ratings:
    205
    Do we know exactly what Valve updated in the SDK? Because I've been having the same problem and while searching the internet for answer, I noticed that in all the compile logs posted, the top of the vrad section has changed:
    Code:
    Valve Software - vrad.exe SSE (Oct 31 2012)
     
    Last edited: Dec 1, 2012
  13. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,834
    Positive Ratings:
    4,753
    I'm having this problem with ventus. I have very few lights, and no texlights. Nothing is wrong in the compile log. I'm very confused :(