1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

WERE DID MY MAP GO!

Discussion in 'Mapping Questions & Discussion' started by Turnip, Sep 19, 2015.

  1. Turnip

    aa Turnip The 80s Vegetable

    Messages:
    1,432
    Positive Ratings:
    803
    I was editing my map, I selected 5 brushes, some with and without editing. (Meaning some were triangular for ramps)
    I went into the texture selctor to change their texture, and when I selected the texture, MY ENTIRE EFFING MAP WAS GONE! NOTHING, NOT EVEN A CRASH, 0 PROPS 0 ENTITIES 0 BRUSHES! I saved hoping it was a crash as that what I would usually do, and immedietly closed hammer hoping to see the auto save file popup.
    I DID NOT, I reopened the map hoping nothing was wrong, and ITS A BLANK FILE NOW!
    How the f*** do I undo this.
    Sorry for the foul language, but this would piss of anyone.
     
  2. Turnip

    aa Turnip The 80s Vegetable

    Messages:
    1,432
    Positive Ratings:
    803
    Ok, I saw an autosave file so it most likely was a crash that saved over the existing file. So I have the same map, 15 seconds before I selected it.
    Still, what happened and how do I prevent it.
     
  3. Crash

    aa Crash func_nerd

    Messages:
    3,191
    Positive Ratings:
    5,018
    Yup. Welcome to Hammer.

    This type of thing happens sometimes. Keeping good autosaves (I personally reduce mine to every 3 minutes) and saving manually often helps a lot. Keeping a few recent iterations doesn't hurt, too.

    I've had to recover full RC maps that have done that. THAT is scary.
     
    • Thanks Thanks x 2
  4. KubeKing

    Server Staff KubeKing dan's birthday was fun too

    Messages:
    1,265
    Positive Ratings:
    1,583
    Crash, you're one to speak.
     
    • Thanks Thanks x 1
  5. Crash

    aa Crash func_nerd

    Messages:
    3,191
    Positive Ratings:
    5,018
  6. Turnip

    aa Turnip The 80s Vegetable

    Messages:
    1,432
    Positive Ratings:
    803
    I set my autosave to every 60 seconds, that gives you some show as to how bad this PC is.
     
  7. Snowbat

    Snowbat L4: Comfortable Member

    Messages:
    165
    Positive Ratings:
    64
    I make maps like I type letters: I hit Ctrl+S like I would hit the trigger of a pistol when firing at something that needs to die multiple times.
     
  8. worMatty

    aa worMatty Repacking Evangelist

    Messages:
    1,072
    Positive Ratings:
    836
    Try not to have a high autosave frequency, as it can cause problem when you are editing entities. Sometimes I find that my input is reverted, if I am editing an entity as the autosave happens. If you have a slow PC, then a very frequent autosave might cause you performance loss. Get in to the habit of hitting Ctrl+S whenever you do something significant.

    So you know, the .VMX file in the same directory as your .VMF is a clone of your last save. When you restart Hammer and it asks you if you would like to open your previous autosave, it's usually best to go along with that but if that does not work you always have the .VMX option.

    I wouldn't be surprised if your 60s autosave had a hand in your map file corrupting. I tried that a while back but decided against it because it caused problems, though I can't remember the details now.
     
  9. Egan

    aa Egan

    Messages:
    1,319
    Positive Ratings:
    1,522
    You may have accidentally hit Ctrl+N instead of any other hotkey like the commonly used Ctrl+M (transform tools). Ctrl+N will open a new .vmf window for 'new map'.
     
    • Thanks Thanks x 1