Unexplained blocky shadow

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

n3dd

L1: Registered
Mar 10, 2018
16
0
Hello, once again, I have another problem regarding shadows. I am trying to fix a prop's ugly shadow appearance, but I cannot eliminate or change it, regardless of the methods I have tried to do.
The prop is rock004.mdl

I have tried the 'mylights.rad' method, which works BRILLIANTLY for the other props but NOT for the prop.
Other methods includes:
- Changing pitch and angel via light_env
- Tried adding env_sun (works for the OTHER props, again)
- Added shadow_control (pitch is -25, shadow pitch is 25)
- Added tonemap_ctrl along with logic_auto
- Disabled Vertex Lighting and Self-Shadowing /w vertex lighting
- Added light_spot

Unfortunately, even by trying one each per compile (I am using HDR full compile -final, due to mylights.rad), the shadow remains the same.

If anyone could help me with this, I'd really appreciate it.
 

Attachments

  • 20180317114650_1.jpg
    20180317114650_1.jpg
    857 KB · Views: 205

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
917
Could you use blocklight to force the shadow to appear correctly?
 

n3dd

L1: Registered
Mar 10, 2018
16
0
is the displacement in that spot intersecting with skybox/nodraw brushes?
Nope. The brush (not displacement) is separated.
Have you tried lowering the lightmap scale?
I've done what you suggested and lowered it to 4, and I've found out the shadow with the 'purple-ish' line is staying, but it seems that there is another shadow there since it goes further than the other one. This other shadow is probably caused by light_spot, which is the GOOD one.
Furthermore, they are not so blocky anymore, which helps solve the problem a bit.
 
Last edited:

n3dd

L1: Registered
Mar 10, 2018
16
0
Right, I somehow fixed the problem.
If anyone has a similar problem, and would like to know what I did in order to fix it, this is what I did:
- I removed the prop from the mylights.rad list. (forcetextureshadow)
- Disabled, and then enabled Shadow on prop
- after this ^, I then enabled vertex light and self-shadowing
- Added back the prop to mylights.rad.

I believe it was disabling the shadow that caused the annoying shadow to disappear. I'm not entirely sure, but it's the possible cause.
Here are two screenshots, the first after I disabled and then enabled the shadow, and the second after I added the prop back to the .rad.
 

Attachments

  • 20180318110853_1.jpg
    20180318110853_1.jpg
    763.8 KB · Views: 166
  • 20180318111836_1.jpg
    20180318111836_1.jpg
    877.3 KB · Views: 155

Tumby

aa
May 12, 2013
1,051
1,100
None of these props should be in a .rad file. You only need to do that when a prop uses transparent textures, and most of these props are already included in the default lights.rad file (which is in the VPKs btw).