[SOLVED] Cannot build cubemaps (Cubemap buffer error)

Discussion in 'Mapping Questions & Discussion' started by Grubzer, May 16, 2019.

  1. Grubzer

    Grubzer L5: Dapper Member

    Messages:
    204
    Positive Ratings:
    39
    When trying to build cubemaps, and error appears:

    Code:
    Cube map buffer size 2048 x 2048 is bigger than screen!
    Run at a higher resolution! or reduce your cubemap resolution (needs 4X)
    
    Problem is, highes resolution available to me is 1920x1080, and even Nvidia's DSR doesn't seem to change anything

    Pls help
     
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,127
    Positive Ratings:
    769
    Why can't you just reduce the cubemap size? 2048x2048 is incredibly high for normal purposes; the default is 32x32 for a reason. What are you generating reflections for that you need reflections of a higher resolution than most players' screens?
     
  3. Grubzer

    Grubzer L5: Dapper Member

    Messages:
    204
    Positive Ratings:
    39
  4. ics

    aa ics http://ics-base.net

    Messages:
    790
    Positive Ratings:
    497
    Do you have very big brushes in the map? Sometimes they can cause issues like this if the surface is too big. Check also alt+p for errors.
     
  5. Grubzer

    Grubzer L5: Dapper Member

    Messages:
    204
    Positive Ratings:
    39
    Alt+p is silent (except no player start), and there are no stupidly big brushes, also, just noticed, all simple light entities now have a glow around them, even without env_sprite
     
  6. iiboharz

    aa iiboharz eternally tired

    Messages:
    761
    Positive Ratings:
    1,104
    Are you running a quality graphics config? I know a handful of em like to change mat_envmapsize despite the fact I believe it's only used for the cubemap buffer when building them. Go ahead and set that to 128 if it's set to anything else.
     
    • Thanks Thanks x 1
  7. Grubzer

    Grubzer L5: Dapper Member

    Messages:
    204
    Positive Ratings:
    39
    [SOLVED] Setting mat_envmapsize and mat_envmaptgasize to 128 fixed the error.
    Thanks to:
     
    • Like Like x 1
    Last edited: May 17, 2019