1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Player hovering on spinning object

Discussion in 'Mapping Questions & Discussion' started by Razor 2, Mar 4, 2018.

  1. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    I'm quite new to hammer and i want to create a floor that is spinning. But when i play in my map i hover on the spinning platform instead of spinning along. How do i fix this?
     
  2. Unregistered HyperCam 2

    Unregistered HyperCam 2 L3: Member

    Messages:
    117
    Positive Ratings:
    4
    Set Solid BSP to true
     
  3. Startacker!

    Server Staff Startacker! L�: Void Walker

    Messages:
    246
    Positive Ratings:
    287
    What brush entity are you using for the platform?
     
  4. Harritron

    Harritron L3: Member

    Messages:
    130
    Positive Ratings:
    70
    Any screenshots of this?
     
  5. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    the platform spins just the player on it doesn't spin along. I don't know what brush entity exactly means but i think it is func_physbox.
     
  6. Unregistered HyperCam 2

    Unregistered HyperCam 2 L3: Member

    Messages:
    117
    Positive Ratings:
    4
    I believe you'll have to either change it to a func_brush or parent a func_brush with the "Solid BSP" keyvalue to it.
     
  7. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    didn't work
     
  8. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    when i change it to func_brush it doesn't spin antmore and if i parent one then it spins but i hover on it, not moving with it.
     
  9. Unregistered HyperCam 2

    Unregistered HyperCam 2 L3: Member

    Messages:
    117
    Positive Ratings:
    4
    How are you spinning it then? Using momentary_rot_buttons?
     
  10. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    with phys_motor
     
  11. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    nvm got it working i just changed it to func_rotating.
     
  12. Unregistered HyperCam 2

    Unregistered HyperCam 2 L3: Member

    Messages:
    117
    Positive Ratings:
    4
    Wait what, I thought func_rotating was broken
     
  13. Razor 2

    Razor 2 L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    idk it works...