No_Entry Respawn Entity Clipping Behind Spawn Door

Discussion in 'Mapping Questions & Discussion' started by Punished Lawbringer, Aug 2, 2018.

  1. Punished Lawbringer

    Punished Lawbringer L1: Registered

    Messages:
    16
    Positive Ratings:
    0
    I currently have four of these entities in a map and they're working as intended. However, there's always one clipping behind a spawn room door no matter how many times I replace it with its counterpart. Looking from the side shows part of it, but it completely disappears the second I look directly at it.

    Not sure if it's a graphical error or not, but checking the compile log holds nothing on it. Anyone know what's causing it?
     
  2. FloofCollie

    aa FloofCollie I really suck!

    Messages:
    563
    Positive Ratings:
    536
    It's quite a common bug and a lot of people have reported it here, yet there doesn't seem to be a fix. It's nothing you've done wrong presumably, but try deleting and remaking the brush. Seems to be a problem with the engine.
     
    • Agree Agree x 2
  3. sz(k)opek

    sz(k)opek L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Had the same problem. Try to add another No_Entry or even two where players won't see it. That's what fixed it for me.
     
  4. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,333
    Positive Ratings:
    896
    Yup, there's no known fix to this, this is a problem that only Valve can fix (and they haven't fixed it for years, so I wouldn't be hopeful). I've seen this on official maps even. It's not your fault.
     
    • Thanks Thanks x 1
  5. Punished Lawbringer

    Punished Lawbringer L1: Registered

    Messages:
    16
    Positive Ratings:
    0
    Yeah, this is something I'll have to check on later then. Remaking it just has the same result. Thanks for the help.