Missing brushes and water textures?!

Discussion in 'Mapping Questions & Discussion' started by Jyyst, Sep 4, 2012.

  1. Jyyst

    Jyyst L1: Registered

    Messages:
    33
    Positive Ratings:
    9
    This weird problem occured when I compiled my map today. In game the map is missing some brushes and all water textures appear as nodraw. I know waterbrushes are there because you can hear water making a sounds when you walk on one of the (nodraw) waterbrushes. :O

    Any idea what is causing this and how to fix it?

    Thank you in advance!
     
  2. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,425
    Do you have a leak? That's a major cause of vanishing water.
     
  3. Jyyst

    Jyyst L1: Registered

    Messages:
    33
    Positive Ratings:
    9
    I fixed all the leaks I found (one :D) but it still doesn't work. :(

    Here are some images just to show you what I mean incase there is a misunderstading.

    [​IMG]

    [​IMG]

    For some reason water does render from below the surfase.

    The current map I'm working on is a underwater facility and I'd like to have some windows with water on the other side.

    [​IMG]
    Pay no attention to the flipped model that looks wrong :p.

    Here the water aint rendering and it wont show up even if I go inside the brush. :confused: Though it might just have something to do with the fact that the brush is pretty slim.
     
  4. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299
    It might be because of your map being fullbright.

    Stick some lights in and try again.
     
  5. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    It might also be because you're using expensive water on multiple planes. Use cheap water only if you're gonna use a lot of it at different heights.

    But it does look like a leak to me.
     
  6. Jyyst

    Jyyst L1: Registered

    Messages:
    33
    Positive Ratings:
    9
    Added lighting. Water still doesn't work :(

    Could it have something to do with my skybox?
    This maps skybox is basicly just a hollow box around the map.
     
  7. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,481
    Positive Ratings:
    1,583
    While it will greatly increase the resources used to play the map, it should not have an effect on the water.

    You could try to change the water. The water from well is a personal favorite of mine.
    If it still doesn't work, I'd love to look at the compile log.
     
  8. Little Dude

    Little Dude L4: Comfortable Member

    Messages:
    172
    Positive Ratings:
    54
    Try copying your map into a new hammer file
     
  9. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,503
    I think you need a cubemap. I've seen this error before.
     
  10. Jyyst

    Jyyst L1: Registered

    Messages:
    33
    Positive Ratings:
    9
    Ty! This fixed it :)