I need help with MvM .Pop files please ;-;

Discussion in 'Mapping Questions & Discussion' started by Q5star, Apr 14, 2017.

  1. Q5star

    Q5star L1: Registered

    Messages:
    24
    Positive Ratings:
    11
    So, i have a map and made the pop file on this website: http://mvm.tf/# (i also tryed a older version to see if it helped but it didn't: http://old.mvm.tf/# )

    Then i added my "mvm_mapname_normal" on my tf/custom/pop/scripts/population and started the map.

    The map keeps saying Wave 0 even tho it kinda read the file (it understood the name and mission name) But not the waves + bots themselves.

    I really don't know what to do here.

    Im currently trying to make the waves and stuff again to see if i did something wrong on the website.

    (Also yes im noob, this is my first mvm map so if it looks like a dumb problem sorry! :c )
     

    Attached Files:

  2. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    You should probably be editing these using something other than standard Notepad. I recommend Notepad++.
     
    • Thanks Thanks x 1
    • Agree Agree x 1
    • Funny Funny x 1
  3. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    Showing console logs (specifically, error messages when the map is loaded) would be helpful.
     
  4. Q5star

    Q5star L1: Registered

    Messages:
    24
    Positive Ratings:
    11
    The ones on the Hammer console or just in-game TF2 console?
    Becouse i don't think the map is reading the pop file itself, only the actual name and mission name. (Probably something wrong on that print i added, i will use notepad++ to see if i find anything.)
     
  5. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    The in-game TF2 console. Hammer doesn't look at pop files. Look for error text that has "CPopulationManager" in it.
     
    • Thanks Thanks x 1
  6. Hyperion

    aa Hyperion L16: Grid Member

    Messages:
    810
    Positive Ratings:
    617
    Very obvious but did you generate nav?
     
    • Thanks Thanks x 1
    • Agree Agree x 1
    Last edited: Apr 15, 2017
  7. Q5star

    Q5star L1: Registered

    Messages:
    24
    Positive Ratings:
    11
    I actually didn't generated nav yet, I thought that would only make the robots move and not really the dettection of the .pop files. Do i really need to do that right now? Also im looking for the CpopulationManager error on the in-game TF2 console, brb.
     
  8. Q5star

    Q5star L1: Registered

    Messages:
    24
    Positive Ratings:
    11
    wow it's full of errors, this was dumb. =P I think i can fix these errors, one of them is actually not having the nav generated yet so thank you both! i'll see if this works, if not i'll just update here.
     

    Attached Files:

  9. theMysteryBoss

    theMysteryBoss L1: Registered

    Messages:
    19
    Positive Ratings:
    1
    i am having the same problem, the console say's that it can't read my pop file...
     
  10. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    Did you put your pop file in tf/scripts/population? (By default there is no "population" folder - make one and put your pop file in there.)

    Also, showing the exact error printout would be helpful so I can tell if it's due to missing pop file or keyvalues error or something.
     
  11. theMysteryBoss

    theMysteryBoss L1: Registered

    Messages:
    19
    Positive Ratings:
    1
    yes i did

    i will try to give you the whole console print if i can find it
     
  12. theMysteryBoss

    theMysteryBoss L1: Registered

    Messages:
    19
    Positive Ratings:
    1
    my console:

    Team Fortress
    Map: mvm_test
    Players: 1 / 32
    Build: 3914266
    Server Number: 3

    The server is using sv_pure 0. (Enforcing consistency for select files only)
    theMysteryBoss connected
    Compact freed 532480 bytes
    Redownloading all lightmaps
    22 bots were already allocated some how before CPopulationManager::AllocateBots was called
    'heavyweapons.cfg' not present; not executing.
    Can't open scripts/population/mvm_test.pop.
    Parse Failed in CPopulationManager::Initialize for scripts/population/mvm_test.popItem Whitelist file 'item_whitelist.txt' could not be found. All items will be allowed.
     
  13. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    Can't open scripts/population/mvm_test.pop.

    You didn't put it in the right folder. It should be in this location (your exact path may vary):

    C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\scripts\population\mvm_test.pop
     
    • Thanks Thanks x 1
  14. theMysteryBoss

    theMysteryBoss L1: Registered

    Messages:
    19
    Positive Ratings:
    1
    thank you so much it worked fine now!!!
     
  15. Mr. DerpedGamer

    Mr. DerpedGamer L1: Registered

    Messages:
    32
    Positive Ratings:
    16
    my console:
    No Nav Mesh CPopulationManager::Initialize for scripts/population/mvm_new05.popCan't compute incursion distances from the Red spawn room(s). Bots will perform poorly. This is caused by either a missing func_respawnroom, or missing info_player_teamspawn entities within the func_respawnroom.
    Can't compute incursion distances from the Blue spawn room(s). Bots will perform poorly. This is caused by either a missing func_respawnroom, or missing info_player_teamspawn entities within the func_respawnroom.
    Can't find blue spawn room nav areas. No legal bomb drop areas are markedNo nav area for bomb delivery zone.Item
    Whitelist file 'item_whitelist.txt' could not be found. All items will be allowed.
    NextBot tickrate changed from 0 (0.000ms) to 7 (0.105ms)
    'scout.cfg' not present; not executing.

    (italicized words were red in the console)
     
  16. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    No Nav Mesh CPopulationManager::Initialize for scripts/population/mvm_new05.pop

    Please try all the suggestions we list here before asking for help or else we might end up repeating ourselves.
     
  17. UKCS-Alias

    aa UKCS-Alias Mann vs Machine... or... Mapper vs Meta?

    Messages:
    1,264
    Positive Ratings:
    748
    Well, 1 suggestion is missing (although the error already does describe it).

    You also need a respawnroom for both red and blue which contain a spawn inside them. These are used to measure walking lengths and can be used by the bots to decide the ideal path to take (and since they go to the red spawn when they reach the hatch and dont have a bomb to pick up that distance is also needed for them). And ofcourse, you need a working hatch.

    Your error in this case refers to the blue spawn
     
    • Thanks Thanks x 1
  18. Mr. DerpedGamer

    Mr. DerpedGamer L1: Registered

    Messages:
    32
    Positive Ratings:
    16
    A: I'm sorry for the inconvenience, but I can be an idiot at times
    B: I thought I did that
    C: I might have done it wrong... I'm new

    I have a blu spawn with a bomb, info_player_teamspawn(s), and a visualizer, so IDK, but again I may have somehow done it wrong.

    Also it always says that it can't find the skybox texture a good 5 times for every compile until I use VIDE, probably completely unrelated, but I thought I might as well mention all the errors incase.
     
    • Agree Agree x 1
  19. Q5star

    Q5star L1: Registered

    Messages:
    24
    Positive Ratings:
    11
    Im actually with the same problem of Mr. DerpedGamer I also have everything but the console says i don't.
    I may have done something wrong so i will remake the spawns i guess?
     
  20. Mr. DerpedGamer

    Mr. DerpedGamer L1: Registered

    Messages:
    32
    Positive Ratings:
    16
    everything is working now, I just didn't know how to generate nav files and that my hill was too steep that the nav files didn't connect the blu spawn to the ground.
    On a side note, when I finished killing off the 10 scouts I put in as a test, I was put into a full-bright version of decoy, completely unrelated but it happened.
     
Tags: