having problems with mvm map and mission.

Discussion in 'Mapping Questions & Discussion' started by basilhs333, Apr 9, 2017.

  1. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    the thing is that when i tried making my map mvm_snowhill and the mission mvm_snowhill_normal.pop it worked fine! but when i did mvm_snowhill_a1 so i can upload the map here after testing it it didnt work.
    and yes i changed the name of the mission to mvm_snowhill_a1_normal.pop but still.
    did i do something wrong?
     
  2. Xelilian

    aa Xelilian That guy with a battleship

    Messages:
    228
    Positive Ratings:
    312
    did you redo your nav mesh? if not it wont work you need a nav mesh for the map so it can work.
     
  3. Hydrogen

    Hydrogen MvM Maniac

    Messages:
    84
    Positive Ratings:
    196
    You did recompile your map when you renamed the map file right?

    Also, the general convention is to name normal mode exactly the same as the pop file. That is, for mvm_snowhill.bsp, make sure you have an mvm_snowhill.nav and mvm_snowhill.pop to go with it (the game won't load a pop file if the map has no nav mesh). The server does <mapname>.pop when searching for the first pop file to load on map start.
     
  4. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    first of all thanks for the help but the problem is one other. i said when i name it mvm_snowhill.bsp it works with the mission mvm_snowhill_normal.pop but when i name it mvm_snowhill_a1 however and the mission mvm_snowhill_a1_normal.pop it doesnt.
     
  5. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    ok i fixed it!
    i just changed the name from mvm_snowhill_a1 to mvm_snowhill(a1) and the pop file to mvm_snowhill(a1)_normal.pop
     
Tags: