Hammer Editor doesn't start anymore

Discussion in 'Mapping Questions & Discussion' started by HashtagMC, Oct 21, 2017.

  1. HashtagMC

    HashtagMC L1: Registered

    Messages:
    15
    Positive Ratings:
    1
    I haven't worked with Hammer for TF2 in a while. Recently, I tried to start it again, but double-clicking either the hammer.exe or hammer.bat has done nothing. Validating local files with Steam didn't change, neither did deleting the entire bin folder and letting Steam re-download it. The recent Jungle whatever update didn't fix this either.

    I checked with the task manager and found that starting Hammer doesn't even launch a process. I just double-click it and nothing happens. The hammer.exe of all the other games (HL2, Gmod, etc.) work. Using Windows 7 64-bit.

    Has anybody experienced this as well and solved it, if so, how?

    Thanks,

    HashtagMC
     
  2. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    356
    Positive Ratings:
    267
    I'm not sure if it's the same, but I have had the problem of Hammer not starting if you have a malformed fgd file listed in your game configuration. So if you're using a custom fgd it might be the problem. Validating the game cache files does not repair the game configurations since they are generated by Hammer. You could try delete the "GameConfig.txt" file in the same directory as Hammer and see if it works.
     
Tags: