Frontline content pack error! HELP!

Discussion in 'Mapping Questions & Discussion' started by Snus Fika, Aug 29, 2016.

  1. Snus Fika

    Snus Fika L1: Registered

    Messages:
    7
    Positive Ratings:
    3
    Help a brother out!

    So, a couple of days ago i found out about the frontline content pack and got eager to try it out. I am quite new to adding custom content to Hammer, so i simply dropped the file into the tf2 game files.

    When i start hammer everything is working like it's supposed to do. All the new custom textures and models are working fine.

    ..Though, in-game..

    The models show as huge errors. I don't understand. The textures are fine, but every single Frontline model becomes an error.
    HOW do I fix this, and WHY is this happening!?

    ------------------------------------------
     
  2. Turnip

    aa Turnip The 80s Vegetable

    Messages:
    1,432
    Positive Ratings:
    803
  3. Snus Fika

    Snus Fika L1: Registered

    Messages:
    7
    Positive Ratings:
    3

    ------------------------

    Thank you thank you! Just wondering, will my gamefiles be damaged if I place the packed content, while the unpacked content is still present? Or do i have to delete the unwanted files?
     
  4. The Letter Before A

    The Letter Before A Cool Idiot

    Messages:
    300
    Positive Ratings:
    119
    When adding any custom content to a map
    (Textures, props, etc) i would recommend writing it down.
    If not packing using vide, compile pal, etc will take hours.
     
    • Like Like x 1
  5. Vel0city

    aa Vel0city func_fish

    Messages:
    1,930
    Positive Ratings:
    1,540
    Hold up folks. If the content shows up in Hammer but not in TF2 on his own pc it has nothing to do with the map not being packed. That's only a concern for people who don't have anything Frontline related.

    For keeping-things-easy-sake, install the Frontline pack in their respective tf/ folders, not in tf/custom. Are you sure the Frontline models are in tf/models, and not anywhere else?

    VIDE should be avoided now, it's crap at detecting custom content outside of the tf/materials or tf/models file structure (and you have to manually let it search for tf/custom and even then it still won't pack everything). CompilePal doesn't care where you located your custom content. If they show up in Hammer, they show up for CompilePal. It's automatic as well. Just let it scan tf/ , and it'll find it all. And it won't take hours. If you manually add every piece of custom content, yes. But with automated packing it'll literary take less than 10 seconds.
     
    • Like Like x 2
  6. Snus Fika

    Snus Fika L1: Registered

    Messages:
    7
    Positive Ratings:
    3

    That might explain the errors, i have not placed the models in their respective place. I hope you know the heavy role you played in this situation. Thank you so much.
     
    • Like Like x 1