Custom textures not loading on server

Discussion in 'Mapping Questions & Discussion' started by ChugMonkey, Mar 17, 2019.

  1. ChugMonkey

    ChugMonkey L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    So, I tried to make a custom map, as a new mapper I used custom textures to make a meme map like Mario Kart. However, every time my friend tries to play it on his server, the textures don't load for him, but load for me. I tried everything. I tried using Ratpack, Vide, Workshop, ect. to get my files to work, I tried including the source files and the texture files, but NOTHING seems to fix it.

    Everything that SHOULD have a custom texture comes up as white when my friend (with the same textures) tries to run it. I'm using the version of Hammer in the TF2/Bin folder and I can see the textures. For reference, heres what my hammer looks like with the textures:
    [​IMG]
    https://imgur.com/a/fHRDn5I

    As you can tell, this is seriously frustrating me as i've spent a total of 14 hours for 2 days trying to fix this and it still doesn't work. I've followed tutorial after tutorial, suggestion after suggestion and nothing works!

    If its any help, my friend is using a server he rents to host a 24/7 server on another game, so it uses a custom URL if thats anything that might effect it.
     
  2. nesman

    aa nesman oh god how did this get here

    Messages:
    443
    Positive Ratings:
    338
    have you tried compilepal? I have had the best of luck with custom content with that
     
  3. dexc34

    dexc34 L2: Junior Member

    Messages:
    75
    Positive Ratings:
    44
    You can try using compilepal, just select the publish prefab, and make sure the "pack" box is ticked. Although most missing textures should be the black and purple checkers, this may be an error with the texture. This can be an issue with your friend running in a lower texture quality or he may be using a config. If that is the case, I would either try using a different texture or tinker with the texture settings