1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Custom models doesn't show up ingame!

Discussion in 'Mapping Questions & Discussion' started by Duck-Joke, Feb 13, 2016.

  1. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    I'm making a map, and i had just found out how to import custom models into it. But when i compile the map and start tf2, there's only errors! pls help!
     
  2. Bogdy

    Bogdy L4: Comfortable Member

    Messages:
    187
    Positive Ratings:
    208
    Are they prop_detail or prop_static?
     
    • Thanks Thanks x 1
  3. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    They are prop_static, but i have also tried prop_dynamic, and that doesn't Work either.
     
  4. henke37

    aa henke37

    Messages:
    1,954
    Positive Ratings:
    465
    You say you get "errors". Do you mean the substitution model or in the developer console?

    Either way, how are you packaging the custom content?
     
  5. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    I mean the 'ERROR' model, that shows up every time. And i put the custom content in steam\steamapps\common\team fortress 2\tf\models or Materials\models
     
  6. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
     
  7. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    960
    Positive Ratings:
    948
    "models or Materials" is not a folder. You have to, quite literally, place it in either "models" or "materials". Model files go in models and material+texture files go in materials.
     
  8. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    I know! That's also what i did!
     
  9. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    i meant steam\steamapps\common\team fortress 2\tf\Materials\models
    and
    steam\steamapps\common\team fortress 2\tf\models
     
  10. Lain

    aa Lain heath ledger with some dreads

    Messages:
    738
    Positive Ratings:
    671
    Do not use custom assets in an alpha version if you are inexperienced.
     
  11. Muddy

    aa Muddy Muddy

    Messages:
    2,396
    Positive Ratings:
    4,249
    Are you running Hammer and/or TF2 from a non-default location? It's possible Hammer is looking in the wrong place for custom content. Go to Hammer's Options menu (Tools > Options...) and make sure Hammer is configured to look in the right directories.
     
    • Thanks Thanks x 1
  12. Duck-Joke

    Duck-Joke L1: Registered

    Messages:
    40
    Positive Ratings:
    4
    Wow. I moved tf2 recently, and i forgot to move the hamme directions with it. Thanks for helping!
     
  13. Muddy

    aa Muddy Muddy

    Messages:
    2,396
    Positive Ratings:
    4,249
    No worries! It happened to me once so I thought I'd ask.