Custom models causing map to crash

Discussion in 'Mapping Questions & Discussion' started by That's the plan, Jun 17, 2019.

  1. That's the plan

    That's the plan L4: Comfortable Member

    Messages:
    183
    Positive Ratings:
    37
    So I'm making a map for a tf2 mod and I used GCFscape to transfer over the rd_asteriod/moonbase props from vanilla tf2 since they weren't included already. The models show up fine in the hammer editor, but when I try and run a map with the custom props it never loads, and just gives a error in the console. I'm not sure if Its because I didn't transfer over all the right files or if it was something else. Any help is appreciated.

    Also, I had troubles porting the same models before using GCFscape, and I made a thread about it: https://tf2maps.net/threads/gcfscape-model-help.39058/#post-457781
     
    Last edited: Jun 17, 2019
  2. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,291
    Positive Ratings:
    858
    What's the error that you got in console?
     
  3. That's the plan

    That's the plan L4: Comfortable Member

    Messages:
    183
    Positive Ratings:
    37
    upload_2019-6-17_21-20-23.png
    I got this error whenever I got in-game, but didn't get any sort of error message in the compile log while compiling the map on normal settings (at least not that I'm aware of)
     
  4. DioJoestar

    DioJoestar L2: Junior Member

    Messages:
    71
    Positive Ratings:
    165
    Not sure, but try to repack a copy of the BSP without compression and then extrack again the models.
    I thought the models were packed with the BSP...