Bots problem

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

MOCOLONI

L6: Sharp Member
Dec 16, 2014
373
88
Although my comment won't be that helpful, I'll just add that on my maps bots don't avoid these areas as well. Whether they're made with brush entities, "nav_avoid" or "nav_mark_attribute AVOID", it just won't work. Perhaps TF2's bots work differently or something broke, a common thing nowadays with other Source functions.
 

Grubzer

L5: Dapper Member
Jan 3, 2016
203
39
Although my comment won't be that helpful, I'll just add that on my maps bots don't avoid these areas as well. Whether they're made with brush entities, "nav_avoid" or "nav_mark_attribute AVOID", it just won't work. Perhaps TF2's bots work differently or something broke, a common thing nowadays with other Source functions.
But in mvm using func_nav_avoid is how bomb carrier controlled
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
917
I think you need to specify tags for it to work.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
917
For example?
Try "common". In MvM, that's the default tag given to every bot. Dunno if it applies outside of MvM, but its worth a shot. If nothing else works, just delete those areas of the navmesh or use a locking door.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
917
Wasn't it a func_nav_prefer entity?
It can be either, or both. Usually nav_avoid is preferred/required as nav_prefer isn't required by bots, only if the prefer area is closer than their destination.