3D Skybox Rendering incorrectly

Discussion in 'Mapping Questions & Discussion' started by n20gaming, Nov 17, 2014.

  1. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    I have setup my skybox correctly, following spaceweasels' tutorial. Look at the pictures for yourself...
    Screenshot #1: The Skybox
    Screenshot #2: The Result - Rendering the map itself
    Screenshot #3: Hammer Editor Screenshot - Skybox
    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Nov 17, 2014
  2. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,392
    Positive Ratings:
    4,236
    You may want to fix those pictures first...

    Also, maybe you've put the sky_camera in the map itself rather than in the skybox.
     
  3. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Updated. The sky_camera was in the skybox as seen in the screenshot above.
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,907
    The images are getting 403 errors. So you can see them, but we can't. They're in the wrong folder, or not in a folder that is public.

    So we can't see the images.
     
  5. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
  6. henke37

    aa henke37

    Messages:
    1,931
    Positive Ratings:
    456
    Erm, what was the problem again? I see nothing wrong in the images...
     
  7. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,907
    So, I'm still not 100% sure whats going on. Could you give us an ingame screenshot in the gameplay area looking around? not just floating above it. So far, I don't see anything out of the ordinary, but I have my suspicions that you've forgotten something like compiling with VVIS.
     
  8. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    The sky_camera renders the accessible part of the map, not the skybox itself.
     
  9. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,907
    I see you have the sky_camera in the skybox area itself, did you leave a second sky_camera in the main accessible part of the map? The entity is very small and very easy to miss, so it's very possible to have missed it.

    If it is in the main accessible part of the map also, you can remove it.
     
  10. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
  11. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    There is clearly only one sky_camera entity.
     
  12. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    I think sometimes this can happen if the 3d skybox is too close to the actual map. Just move it a bit further away.

    But I rather think you are having a different error like a leak. Did you check your compile log? or can you just post it here?
     
  13. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    951
    Positive Ratings:
    937
    Have you made sure that the origin of the map and the sky_camera entity are in the correct place?

    Use the [ Map > Entity Report... ] Button to see if there really is only 1 sky_camera entity.

    Did you change any properties in the sky_camera?
     
    • Thanks Thanks x 1
  14. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,907
    I can not tell that there is only 1 sky camera, if you only show 1 in-hammer shot of a sky camera in the skybox, and not the hammer of the main accessible map.


    Try what someone suggested above, and moveing the skybox away.
     
  15. henke37

    aa henke37

    Messages:
    1,931
    Positive Ratings:
    456
    I recommend that you just post the vmf file, screenshots aren't working here.
     
  16. n20gaming

    n20gaming L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Code:
    ** Executing...
    ** Command: "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\tf" "C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout.vmf"
    
    Valve Software - vbsp.exe (Nov  3 2014)
    4 threads
    materialPath: C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout.vmf
    Patching WVT material: maps/tr_loadout/egypt/sand_floor_blend_04_with_grass_wvt_patch
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****
    Entity prop_static (708.00 -440.00 -16.00) leaked!
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (-512.0 10240.0 1672.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9864.0 1672.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9352.0 3368.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9352.0 3216.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9352.0 1520.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 8584.0 1672.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9096.0 3368.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (0.0 9096.0 3216.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    *** Suppressing further FindPortalSide errors.... ***
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_dustbowl_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_dustbowl_01 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_dustbowl_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_dustbowl_01 to build the default cubemap!
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    WARNING: Map using power 4 displacements, terrain physics cannot be compressed, map will need additional memory and CPU.
    done (1) (257881 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 107 texinfos to 66
    Reduced 20 texdatas to 17 (551 bytes to 440)
    Writing C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout.bsp
    9 seconds elapsed
    
    ** Executing...
    ** Command: "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\tf" "C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout"
    
    Valve Software - vvis.exe (Nov  3 2014)
    4 threads
    reading c:\users\acer\desktop\nathan\valve map decompiler\my maps\tr_loadout.bsp
    reading c:\users\acer\desktop\nathan\valve map decompiler\my maps\tr_loadout.prt
    LoadPortals: couldn't read c:\users\acer\desktop\nathan\valve map decompiler\my maps\tr_loadout.prt
    
    
    ** Executing...
    ** Command: "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters:  -game "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\tf" "C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout"
    
    Valve Software - vrad.exe SSE (Nov  3 2014)
    
          Valve Radiosity Simulator     
    4 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']
    
    Loading c:\users\acer\desktop\nathan\valve map decompiler\my maps\tr_loadout.bsp
    No vis information, direct lighting only.
    Setting up ray-trace acceleration structure... Done (1.31 seconds)
    428 faces
    209001 square feet [30096226.00 square inches]
    4 Displacements
    12735 Square Feet [1833873.00 Square Inches]
    sun extent from map=0.087156
    18 direct lights
    BuildFacelights:     0...1...2...3...4...5...6...7...8...9...10 (7)
    Build Patch/Sample Hash Table(s).....Done<0.0127 sec>
    FinalLightFace:      0...1...2...3...4...5...6...7...8...9...10 (0)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (9)
    Writing leaf ambient...done
    Ready to Finish
    
    Object names       Objects/Maxobjs  Memory / Maxmem  Fullness 
    ------------       ---------------  ---------------  -------- 
    models                   8/1024          384/49152    ( 0.8%) 
    brushes                 70/8192          840/98304    ( 0.9%) 
    brushsides             439/65536        3512/524288   ( 0.7%) 
    planes                 336/65536        6720/1310720  ( 0.5%) 
    vertexes               720/65536        8640/786432   ( 1.1%) 
    nodes                  481/65536       15392/2097152  ( 0.7%) 
    texinfos                66/12288        4752/884736   ( 0.5%) 
    texdata                 17/2048          544/65536    ( 0.8%) 
    dispinfos                4/0             704/0        ( 0.0%) 
    disp_verts            1156/0           23120/0        ( 0.0%) 
    disp_tris             2048/0            4096/0        ( 0.0%) 
    disp_lmsamples       34372/0           34372/0        ( 0.0%) 
    faces                  428/65536       23968/3670016  ( 0.7%) 
    hdr faces                0/65536           0/3670016  ( 0.0%) 
    origfaces              188/65536       10528/3670016  ( 0.3%) 
    leaves                 490/65536       15680/2097152  ( 0.7%) 
    leaffaces              510/65536        1020/131072   ( 0.8%) 
    leafbrushes            155/65536         310/131072   ( 0.2%) 
    areas                    3/256            24/2048     ( 1.2%) 
    surfedges             2668/512000      10672/2048000  ( 0.5%) 
    edges                 1503/256000       6012/1024000  ( 0.6%) 
    LDR worldlights         18/8192         1584/720896   ( 0.2%) 
    HDR worldlights          0/8192            0/720896   ( 0.0%) 
    leafwaterdata            0/32768           0/393216   ( 0.0%) 
    waterstrips             34/32768         340/327680   ( 0.1%) 
    waterverts               0/65536           0/786432   ( 0.0%) 
    waterindices           489/65536         978/131072   ( 0.7%) 
    cubemapsamples           2/1024           32/16384    ( 0.2%) 
    overlays                 2/512           704/180224   ( 0.4%) 
    LDR lightdata         [variable]      331876/0        ( 0.0%) 
    HDR lightdata         [variable]           0/0        ( 0.0%) 
    visdata               [variable]           0/16777216 ( 0.0%) 
    entdata               [variable]       15781/393216   ( 4.0%) 
    LDR ambient table      490/65536        1960/262144   ( 0.7%) 
    HDR ambient table      490/65536        1960/262144   ( 0.7%) 
    LDR leaf ambient      2779/65536       77812/1835008  ( 4.2%) 
    HDR leaf ambient       490/65536       13720/1835008  ( 0.7%) 
    occluders                0/0               0/0        ( 0.0%) 
    occluder polygons        0/0               0/0        ( 0.0%) 
    occluder vert ind        0/0               0/0        ( 0.0%) 
    detail props          [variable]           1/12       ( 8.3%) 
    static props          [variable]           1/17412    ( 0.0%) 
    pakfile               [variable]         856/0        ( 0.0%) 
    physics               [variable]      257881/4194304  ( 6.1%) 
    physics terrain       [variable]           0/1048576  ( 0.0%) 
    
    Level flags = 0
    
    Total triangle count: 1059
    Writing c:\users\acer\desktop\nathan\valve map decompiler\my maps\tr_loadout.bsp
    17 seconds elapsed
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Users\Acer\Desktop\Nathan\Valve Map Decompiler\My Maps\tr_loadout.bsp" "C:\Program Files\Hiddan\FLavio\steamapps\common\Team Fortress 2\tf\maps\tr_loadout.bsp"
    
    
    It was leak. Tried also your other tips if it could help. I'll check it...

    [EDIT]
    Code:
    Entity prop_static (708.00 -440.00 -16.00) leaked!
    It was a leak. Loaded a pointfile, sealed it and voila! It works like a charm. Thanks for the help!
    Now... I'll need to find a way on how to close thread...
     
    Last edited: Nov 17, 2014
  17. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Closing threads like that is pointless imo. what if it didn't work after all? What if someone would still like to have mentioned here? Just leave it open just in case~ And always check for leaks first when you have trouble