weird error texture on glass

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Billo

aa
Feb 8, 2016
888
it's weird. i made many maps and in some i dont find this problem but in other maps like mvm_snowflake i can't fix it. what should i do in order to fix the problem? i would be very happy to get an answear as soon is possible thanks :D

http://imgur.com/a/XJKbd
 

PenolAkushari

Never Played MvM
Apr 28, 2017
51
I think that's because of missing "cubemaps". Those are supposed to be made in-game by engine, once you'll put "buildcubemaps" command in console or something like that, after what they'll be built-in bsp. Though, to make things a but more prettier, you'll need cubemap entity near those reflective textures and stuff, as "reference" where to build them.

A bit more info can be found on Valve's hammer and stuff wiki, so here it is: https://developer.valvesoftware.com/wiki/Cubemaps
 

Billo

aa
Feb 8, 2016
888
so i just launch the map and on the consol i write buildcubemaps and thats it? cause i tried adding the cubemaps close to the window but it didnt work.
 

PenolAkushari

Never Played MvM
Apr 28, 2017
51
Supposed to be like so. Though, as mentioned on Valve wiki, it's also suggested to set mat_specular to 0 before loading map, to sped up the process. And I think that's supposed to be it, though, you got at least one cubemap entity on map? Because I think otherwise it might screw up something.
 

henke37

aa
Sep 23, 2011
2,075
It's not for speed reasons. It's to avoid capturing bad reflections in the new cubemaps.
 

PenolAkushari

Never Played MvM
Apr 28, 2017
51
Seems like I misread some stuff on wiki. Pardon for misinformation here, missed that they told to do mat_specular 0 before loading the map to sped up the process, since while map would be loaded in and then mat_specular 0 would be done, then it would "get stuck" loding stuff for some time.
 

MOCOLONI

L6: Sharp Member
Dec 16, 2014
373
Seems like I misread some stuff on wiki. Pardon for misinformation here, missed that they told to do mat_specular 0 before loading the map to sped up the process, since while map would be loaded in and then mat_specular 0 would be done, then it would "get stuck" loding stuff for some time.
I myself wrote that since it was a much more efficient method. I don't know if anybody else realized that loading a map with "mat_specular 1" to later switch to "0" is just pointless and a waste of time, along that other "mat_reloadallmaterials" command, but either way it wasn't posted on the wiki. That command is also automatically fired if loading a map with sv_cheats enabled for some reason, which Does freeze your game and actually nothing else besides that.