Ugly Shadows

Discussion in 'Mapping Questions & Discussion' started by Fizzld, Jan 26, 2018.

  1. Fizzld

    Fizzld L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Hi, I feel like I'm asking for help constantly so I hope y'all don't mind

    I've put down some trees and under them are some VERY UGLY shadows. The trees are using the same properties as the ones found in sawmill, but as you can see from the screenshots, the way the shadows have generated is very different. Anyone got a fix?

    Mine:
    [​IMG]
    [​IMG]
    vs
    Valve's (same properties)
    [​IMG]
    [​IMG]

    As you can see, my trees are creating huge, ugly, pitch black shadows under the entire prop, while valve's are creating small, round, lighter shadows under each individual tree.
     
  2. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,429
    Positive Ratings:
    1,173
    It's not just about the properties of the models, but also the settings the map is compiled with, specifically the settings you pass to vrad.exe. Have a thorough read of this article on Nodraw.net.
     
    • Agree Agree x 2
    • Thanks Thanks x 1
  3. iiboharz

    aa iiboharz Meme Queen

    Messages:
    707
    Positive Ratings:
    1,030
    More specifically on what Crowbar said, by default shadows for models are generated based on their collision mesh (or even just the bounding box) because they're usually composed of much simpler shapes, which can result in really ugly, blobby shadows. The -staticproppolys command forces the compiler to use the actual mesh for shadows.
     
    • Thanks Thanks x 1
    • Agree Agree x 1
  4. Harritron

    Harritron L2: Junior Member

    Messages:
    77
    Positive Ratings:
    31
    Had a similar issue the other day. -staticproppolys and -staticproplighting should fix this, however, this will significantly increase your compile time. Save this until your last compile, but definitely visit nodraw.net as Crowbar suggested. There are also many other tutorials on there that may come in handy in the future.
     
    • Thanks Thanks x 1
    • Like Like x 1
  5. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    in my experience it increases compile time by only 20-30%. I always leave it on, gives a better idea for the final compile. It only increases compile time massivly if you use a custom lights.rad to emit lights from textures with low lightmap scale.