Ugly shadows on my map while my lightmap scale is 24

Discussion in 'Mapping Questions & Discussion' started by Seitan, Mar 24, 2017.

  1. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    My map has a lightmap scale with a value of 24 and I'm still getting these ugly shadows, also I tried with 16 lightmap scale and I'm still getting the same ugly shadows:

    http://imgur.com/a/dnNC0

    Maybe the light entities are too close to the walls?
     
  2. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,841
    Positive Ratings:
    4,765
    Moving the light entities away will reduce the pixellation yes.

    However this looks normal for a 16 lightmap scale (Why are you using 24 anyway? 16 is usually more than fine), reducing it further will alleviate some of the pixellation but at the same time VRAD is just bad sometimes.
     
    • Like Like x 1
  3. worMatty

    aa worMatty Repacking Evangelist

    Messages:
    1,072
    Positive Ratings:
    833
    Strong contrasts, i.e. lights shining on very dark walls also makes lightmaps look bad, probably because the gradient from light to dark can't be smoothly rendered with such a low number of luxels (units of light on a lightmap). Brightening the environmental lighting a bit will help, too. That basically makes the baseline darkness closer to the brightness so it's less of a distance between them.
     
  4. iiboharz

    aa iiboharz Meme Queen

    Messages:
    707
    Positive Ratings:
    1,030
    I would strongly suggest keeping your lightmaps on a power of 2.

    If you want a more detailed shadow, lower the lightmap scale to something like 8 or 4. But be careful as this will inflate the compile time and resulting map size as it has to provide more lightmap data.

    https://developer.valvesoftware.com/wiki/Lightmap#Lightmap_Scale
     
  5. Micnax

    aa Micnax I maek map

    Messages:
    2,056
    Positive Ratings:
    1,382
    The lower the lightmap number, the more high resolusion the shadow will be (but the shadows on that face will increase filesize).

    Using 24 over the default 16 will in fact make it look worse :p
     
    • Thanks Thanks x 1
  6. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I will try changing my lightmap scale to 2 or 8, thanks
     
  7. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I changed my lightmap scale from 16 to 4 and I'm still having ugly shadows on those spots, I will try moving the light entities away from the walls
     
  8. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    FYI those light fixtures probably ought to use light_spot entities angled down the same way as the fixtures themselves. That'd fix your problem as well as making the lighting more true-to-life.
     
  9. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I compiled my map and received a couple of leak warnings, I fixed the leaks and now all of my singleplayer games are mat_fullbright 1, it won't turn off, mat_fullbright 0 doesn't work, my singleplayer games are stuck at mat_fullbright 1, it's like setting it to 0 doesn't work anymore.
     
  10. hutty

    aa hutty

    Messages:
    471
    Positive Ratings:
    372
    A couple things, you might still have leaks, if unsure check the compile log and toss it into the error checker on http://www.interlopers.net/errors/

    Also, when you say changing the lightmap scale of the map, are you changing the specific faces using the face select tool? Or are you doing something else.