Swamp theme particle systems

Discussion in 'Mapping Questions & Discussion' started by Grubzer, Jun 2, 2016.

  1. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    28
    I used swamp theme particle systems in my map, but they not appeared in game. "Attempting to create unknown particle system 'env_buoy_flash' ". Help me please.
     
  2. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    No matter if you pack or not, it will say hat error. Did you actually check to see if the particle was working in game?
     
    • Agree Agree x 1
  3. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    28
  4. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
    You have to create a particle manifest for custom particles to work. It's basically a pre-caching thing that Source does. If a particle is not specified, TF2 will not load it and then complain about trying to make a particle system that isn't there.

    Read it up here: https://developer.valvesoftware.com/wiki/Particles_manifest.txt
     
    • Thanks Thanks x 1
    • Agree Agree x 1
  5. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    28
    Thank you! i created them earlier, but i forgot to add _a1 to the end. Thank you!
     
  6. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    28
    and how to pack thoes particles into my map? So people who dont have that manifest can see them too?
     
  7. iiboharz

    aa iiboharz Meme Queen

    Messages:
    707
    Positive Ratings:
    1,030
    You have to pack the manifest into your map as well as the particles themselves.
     
    • Thanks Thanks x 1
  8. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    28
    ok
     
Tags: