Strange Lighting Problem (not a shadow problem)

Discussion in 'Mapping Questions & Discussion' started by FissionMetroid101, Feb 17, 2010.

  1. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
    Hello everyone, I'm very new with mapping so please bear with me. I'm working on a zf_nucleus map, and I'm trying to make it very dark, but after setting some lighting settings on lighting_env to a dark setting, it did the opposite:
    [​IMG]
    It's not the machine's lights causing it, I've messed with it's mouth's lights, and no change.
    The numbers in light_env are:
    Brightness - 58 58 58 450
    Ambient - 60 65 79 150
    BrightnessHDR - 97 97 97 450
    AmbientHDR - 97 97 97 450
     
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,557
    Judging by the light source it's coming from the machine. However, i believe the 'glow' effect is a func_dynamic, which doesn't cast light.

    You have something in the middle casting huge amounts of light. Potentially you have high HDR settings, but it looks more like a direct light source to me.


    Scratch that:
    Leave them as 1 1 1 1 (or what ever the default is). Then see what your map looks like.
     
  3. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
    Nothing different happened... I remember getting the light to work once, but I only lowered the numbers slightly and it was when I started making the map.
     
  4. Tapp

    Tapp L10: Glamorous Member

    Messages:
    776
    Positive Ratings:
    211
    Change the HDR values, 450 is really high, especially for an ambient brightness. Also, I know you said it isn't, but those shadows ALL point toward the control point.
     
  5. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
    Alright, I'll go alter the HDR lights. I've looked about 6 times through the machine, and there's no stray lights. I've set the natural CP lights to flicker, but no supreme light changes.
     
  6. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
  7. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,557
    [​IMG]

    Show us a hammer shot of what's in this area?? and turn off prop models in the visgroup.
     
  8. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
  9. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
    Found the error, they put 4 lights in the teeth of the mouth. :cursing:
    [​IMG]
     
    Last edited: Feb 18, 2010