[SOLVED] odd hammer texture bug

Discussion in 'Mapping Questions & Discussion' started by Donatello, Jan 14, 2017.

  1. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    It's hard to explain but here is a picture:
    [​IMG]map doesn't compile as well (when using this texture)
     
  2. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,439
    Positive Ratings:
    1,186
    Looks much like if you took a lightmap view and inverted the colors of faces in that view.
     
  3. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    what do you mean?
    I made the texture myself and had never problems with custom textures.
     
  4. worMatty

    aa worMatty Repacking Evangelist

    Messages:
    1,072
    Positive Ratings:
    834
    There are three things that come to mind:
    • Your custom material's VMT file may not be configured correctly.
    • That brushwork may be invalid. Do you only see the problem here? If so, try deleting and recreating it.
    • Your VMT may be using a transform to manipulate the rotation of the texture. Hammer has trouble displaying materials with transforms in the 3D viewport. An example is the security glass material.
    Would you mind copying your custom material's VMT file contents into the thread?
     
  5. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    I fixed it by redoing everything.
    My vmt file looked like the same as any other.