Particles spawning at world origin

Discussion in 'Mapping Questions & Discussion' started by Grubzer, Jul 30, 2016.

  1. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    I created custom particles, in particle editor they looking ok, but in game they are spawning not at position of info_particle_system, but at world origin (red green and blue lines in hammer)
     
  2. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,540
    Welcome to Source. We had this problem on pd_snowville as well. I'll ping @Exactol for you, he's good with particles (and did some of them on Snowville). I forgot what caused it, maybe he remembers.
     
    • Thanks Thanks x 1
  3. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    Is there any particle sprite per map limit?
     
  4. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,540
    I'm sure there is, but you'd be doing some utterly crazy stuff before you hit that limit.

    I think it had to do with a certain particle type just wanting to be at the map origin instead of near the particle system. Don't know what it is though.
     
  5. Exactol

    aa Exactol Certified Hammer Hacker

    Messages:
    401
    Positive Ratings:
    472
    You probably don't have an initializer that specifies where the particle spawns. You must have something like spawn in sphere random, or spawn in square random, even if you leave all of their fields blank.
     
  6. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    So, what i should do?
     
  7. Joshenkstone

    Joshenkstone L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    177
    you should add a initializer for radius within box (or shpere) random. if you don't edit any of the values it should (maybe) work.
     
  8. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    Thank you, your tip helped me with on particle. But another one which have orientation type set to 2 is still spawning at world origin
     
  9. Joshenkstone

    Joshenkstone L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    177
    in the info_particle_system try typing cpoint1 <particle location> after "Control Point 1, if that doesn't work just make different particles with a different orientation so you don't have to rotate the in hammer. also note that with normal animated sprite particles you don't have to set a different orientation as it will always be facing you.
     
  10. Grubzer

    Grubzer L4: Comfortable Member

    Messages:
    186
    Positive Ratings:
    36
    i set orientation like teleporter particles/ and what do you mean under particle location?
     
  11. Joshenkstone

    Joshenkstone L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    177
    the x y and z axes for the location of the info_particle_system