1. On August 16th at 9pm CST, the site will be put in to read only mode for maintenance. Maintenance should not take longer than an hour.

Oldest Respawn room visualizer won't display

Discussion in 'Mapping Questions & Discussion' started by bluewatermelonexplosion, Aug 21, 2017.

  1. bluewatermelonexplosion

    bluewatermelonexplosion L1: Registered

    Messages:
    9
    Positive Ratings:
    3
    So I've been trying to get respawn room visualizers to work, but it turns out that the oldest respawn room visualizer won't display (it won't become visible, haven't checked to see if it won't block).

    How do I fix this? Seems like a really odd thing to happen and it's holding me up.

    Thanks.
     
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    756
    Positive Ratings:
    513
    Is the respawnroom visualizer rendering behind the door? Sometimes they do that.
     
  3. squ1rrel

    squ1rrel L4: Comfortable Member

    Messages:
    156
    Positive Ratings:
    70
    Used to get this sometimes. No idea as to why it happens but I just ended up re-making all of them an eventually they worked.
     
  4. bluewatermelonexplosion

    bluewatermelonexplosion L1: Registered

    Messages:
    9
    Positive Ratings:
    3
    The visualizers are in front of the door by 8 hammer units originally, but I boosted them an extra 4 hammer units so they are sticking out of the door frame, so it's not being hidden.

    In fact, doing that made me realize that not only is the oldest visualizer not displaying, it isn't blocking either.

    I looked through the compile log and there's only a skybox error which doesn't do anything.

    I've remade them once from scrap, and a few times by copying while changing the associated func_respawnroom, and I get the same result every time.

    I appreciate the help. I'm considering renaming this version to see if that will do anything.
     
  5. bluewatermelonexplosion

    bluewatermelonexplosion L1: Registered

    Messages:
    9
    Positive Ratings:
    3
    Okay, so what I did to get around this bug(?) is by copying the currently broken respawn visualizer directly in the same place, keeping both.

    Since the broken respawn visualizer if removed will break a different one (the next oldest if my theory is right), we need to keep it, but we need to add a working one in its place, and since the broken one won't show up in map (not even sure if it is compiled) it shouldn't cause any problems to have a working duplicate in the same place.

    If anyone knows an actual fix, it'd be appreciated, but for now, this should work for anyone with this problem.

    Just keep in mind if the problem goes away on its own you'll need to delete one of the stacked visualizers.
     
    • Thanks Thanks x 3