[Noob question]Really ugly Texture blends

Discussion in 'Mapping Questions & Discussion' started by Ingerwolf, Mar 16, 2010.

  1. Ingerwolf

    Ingerwolf L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    Im making my first map and im noticing some very ugly texture blends, between the two walls like so:
    [​IMG]

    the blends of light and the textures are ugly so noob question what fixxes this? :blink:
     
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    Did you compile vrad on fast?

    It just looks like non-merged lightmaps. The wall has been cut into several faces, and along one seem the shadow is not blending across it due to lightmaps not merging/blending.

    http://forums.tf2maps.net/showthread.php?t=1693&highlight=lightmaps

    Using normal vrad settings should prevent this from happening.

    If all else fails, use smoothing groups.
     
    • Thanks Thanks x 1
    Last edited: Mar 16, 2010
  3. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    I don't see any light bouncing back at the ceiling, so I assume your problem is caused by a leak. These are caused when VVIS, a program critical to optimization and lighting, cannot run because it is unsure where your map is separated from an area outside of your map known as the void. To fix it, you'll need to review your compile log. If it has several errors and the text "*** LEAKED ***" at the end of your VBSP, you have a leak. Assuming you do have a leak, you'll need to load your map's pointfile. Under the map menu, an option should say "Load Pointfile". Clicking that should automatically load a pointfile, or ask you to specify a file if you have no leak in your map. Once loaded, you should see a red line somewhere in your level (usually coming out of the center of an entity.) Follow that line and it should manage to escape your geometry. You want to fix it so that it can't leave no matter what path it takes.

    Keep in mind that leaks aren't sealed by glass, displacements, brushes tied to entities (including func_detail), or props, only actual brushwork!
     
  4. Ingerwolf

    Ingerwolf L1: Registered

    Messages:
    7
    Positive Ratings:
    0
    From what i understand its not a leak although thank you for the info. As for the lightmaps I think thats the problem. Thanks for the link
     
  5. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    Just incase, and for future reference, paste your compile log into: http://www.interlopers.net/errors/

    It will automatically check your log for errors and tell you what errors you have and how to solve them (if they need resolving, some compile errors are not game/map breaking).
     
  6. honeymustard

    honeymustard L9: Fashionable Member

    Messages:
    698
    Positive Ratings:
    273
    I had this problem, it's just lightmaps not lining up. Turn on the grid in the 3D camera view and line them up.