None of my entities will load

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

Jack_Magma26

L1: Registered
Nov 11, 2017
9
I've just started mapping and I'm not sure what is causing the problem or how to fix it

*edit* no more problems. I Copied it into a new map and everything appears to be working


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull.vmf"

Valve Software - vbsp.exe (Oct 14 2017)
4 threads
materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull.vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Patching WVT material: maps/bunkerdown_control_pointsfull/dev/dev_blendmeasure2_wvt_patch
Patching WVT material: maps/bunkerdown_control_pointsfull/nature/blendconcretetograss002_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
**** leaked ****
Entity prop_dynamic (5316.00 -212.00 -144.00) leaked!
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (1)
*** Error: Skybox vtf files for skybox/Sky_alpinestorm_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/Sky_alpinestorm_01 to build the default cubemap!
*** Error: Skybox vtf files for skybox/Sky_alpinestorm_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/Sky_alpinestorm_01 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (1) (154212 bytes)
Error! To use model "models/props_frontline/tank_animated.mdl"
with prop_static, it must be compiled with $staticprop!
Error loading studio model "models/props_frontline/tank_animated.mdl"!
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 618 texinfos to 501
Reduced 21 texdatas to 19 (566 bytes to 513)
Writing C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull.bsp
Wrote ZIP buffer, estimated size 1122, actual size 908
8 seconds elapsed

** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull"

vvis launcher error: can't load vvis_dll.dll
The specified procedure could not be found.


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -noextra "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull"

vrad_launcher error: can't load vrad_dll.dll
The specified procedure could not be found.


** Executing...
** Command: Copy File
** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\BunkerDown_Control_pointsfull.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\BunkerDown_Control_pointsfull.bsp"


** Executing...
** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2.exe"
** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" +map "BunkerDown_Control_pointsfull" -steam
 
Last edited:

trees

L2: Junior Member
Apr 1, 2017
76
Did you check your visgroups? If you've hidden the entity visgroup then entities won't be compiled.
 

VEssex

L2: Junior Member
May 19, 2016
76
vvis launcher error: can't load vvis_dll.dll
The specified procedure could not be found.
vrad_launcher error: can't load vrad_dll.dll
The specified procedure could not be found.

Install the runtime, this is in order to fix vvis and vrad because they aren't working.

**** leaked ****
Entity prop_dynamic (5316.00 -212.00 -144.00) leaked!

Also, you have a leak, there is a hole in the map brushwork leaking into the void.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
Did you check your visgroups? If you've hidden the entity visgroup then entities won't be compiled.
Entity prop_dynamic (5316.00 -212.00 -144.00) leaked!
A prop_dynamic leaked, which means entities had to be included in the compile.

Jack, you'll need to be more specific. Which entities aren't appearing? All of them or only certain ones? Does it happen to be a tank static prop that's not appearing?
Error! To use model "models/props_frontline/tank_animated.mdl"
with prop_static, it must be compiled with $staticprop!
This error means that you have a prop type mismatch. This animated tank model isn't meant to be used as a prop_static. You'll need to check the prop types supported by this prop and use one of those (a prop_dynamic should work with this model).

VEssex also notes other problems you have, but AFAIK they're not related to the specific problem you described in this thread.