Need help with map not running in Hammer

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.
  • If you're asking a question make sure to set the thread type to be a question!
  • Something not downloading? Download authors read this.

Sanic2quick

L1: Registered
Jun 26, 2019
1
0
I have recently come across a strange issue with my map in Hammer. For my map, I've boxed it all up inside a sky box, making sure there were no leaks anywhere on the map. However, Hammer would freeze up when trying to run my map. Strangely, if I remove a piece of the sky box, like the ceiling, the map will run just fine. I have no idea what the issue is and have not found every solution to fix it.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,339
994
Hammer will often enter a "Not Responding" state while compiling; this is an oversight in the compilers and is to be expected if the compile process is working correctly. All that is needed is a bit of patience. The VBSP part of your process should only take seconds, VVIS should take from a few seconds to a few minutes depending on how complex and well optimized your map is, and VRAD will usually take the longest. You can speed up or disable any part of this process (except VBSP) and still get a working map, but important data about your map will be left out by doing so (VVIS optimizes your map while VRAD adds lighting), so only use those for test compiles. Both VVIS and VRAD can't do all of their important calculations if they can't separate the inside and outside of your map, which is why deleting a skybox wall and creating a leak will make your compile faster. See this video for more info.