MvM Spies and Engineer bots not teleporting

Discussion in 'Mapping Questions & Discussion' started by _Arad_, Jan 22, 2018.

  1. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    i created a mvm map which has a bot_hint_engineer_nest and all that stuff. but, when i put an attribute to an engineer: "TeleportToHint" in the pop file, it doesnt teleport/spawn at all. also, my spies can spawn, but they dont teleport somewhere into the map. any help?
     

    Attached Files:

  2. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    i havent downloaded your map but this reminds me of a problem i had and the solution was simple. i had forgotten to do a nav mesh or at least redo it cause any changes you make may effect the nav too so yea
     
  3. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    but listen, my spies dont teleport and i dont know how to make them teleport + my engineers dont teleport to a specific place, and i didnt do any changes in the map itself
     
  4. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    okay,
    what do you use for the pop? i mean its the coding that makes the bots and stuff you know.
    i use mvm.tf and i didnt have a problem. try it for yourself if you havent already, it might turn out to be good for you : https://mvm.tf/
    with that i managed in my mvm map to make engineers and spies spawn when i wanted so yea , i hope i helped
     
  5. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    Well, I know how to code a pop file from scratch and mvm.tf only allows the default valve maps and we're talking about a custom map.
     
  6. Da Spud Lord

    aa Da Spud Lord L0: Shitty Member

    Messages:
    540
    Positive Ratings:
    383
    Didn't have a problem? In the version of Snowflake I tested, your map had gatebots, waves were unlosable, and I got stuck in waves 6 and 7 cuz robots stopped spawning.

    Many people have complained that mvm.tf produces broken popfiles. When I made an MvM map, I used old.mvm.tf and experienced no troubles with broken popfiles, but if you can make the popfiles by hand, you're better off doing that.
     
  7. basilhs333

    basilhs333 L8: Fancy Shmancy Member

    Messages:
    562
    Positive Ratings:
    136
    yes sure which version though?
    the latest or one of alpha?
    cause i playtested the latest version many times and i was fine
     
  8. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    Now I decided that the engineers won't teleport but spawn normally like in mannhattan, but the spies are still problematic. Any fix?
     
  9. Benoist3012

    Benoist3012 L3: Member

    Messages:
    145
    Positive Ratings:
    201
    Fix your nav, regenerate it, you are likely missing hiding spots on your nav.
     
  10. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    All I do is nav_generate in the console. How do I add hiding spots?
     
  11. Benoist3012

    Benoist3012 L3: Member

    Messages:
    145
    Positive Ratings:
    201
    You don't, the game does that for you.

    Edit: Also make sure spy aren't stuck in a brush when spawning. Also do not noclip while testing, you have to be on ground when they spawn.
     
  12. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    But it still doesn't work
     
  13. Benoist3012

    Benoist3012 L3: Member

    Messages:
    145
    Positive Ratings:
    201
    Forgot to ask the obvious, but your map is flat? No obstacle nothing? Add some walls and rooms, then regenerate the nav and try.
     
  14. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    Well, my map is literally called flat.
     
  15. henke37

    aa henke37

    Messages:
    1,837
    Positive Ratings:
    420
    Spybots only spawn out of PVS. If the player could possibly have seen the visleaf they would've spawned in, they won't spawn.
     
  16. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    That's not it, they spawn but not teleport.
     
  17. Benoist3012

    Benoist3012 L3: Member

    Messages:
    145
    Positive Ratings:
    201
    Or in short words, if a ray can be traced from player pos to the hiding spots from the nav then the spy bot won't spawn there, that's why I told him to add walls on his map, but so far he hasn't answered back on this.
     
  18. _Arad_

    _Arad_ L1: Registered

    Messages:
    9
    Positive Ratings:
    0
    School.
     
  19. Fillmore

    Fillmore L2: Junior Member

    Messages:
    82
    Positive Ratings:
    76
    TeleportToHint requires the bomb to be far enough from sentry hints before they are considered valid.

    Everyone else has said enough about the spy problems that I have nothing to add.
     
  20. Da Spud Lord

    aa Da Spud Lord L0: Shitty Member

    Messages:
    540
    Positive Ratings:
    383
    *Close enough. The bomb has a radius, within which engineer bots will use hints.